This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Raja Mohammed 1 year, 4 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
November 23, 2018 at 3:50 pm #2934747


Tell us what you are trying to do?
My client has English and Dutch on their website - they use two languages combined. So for example one blogpost about yogapants is in English and another one about organic food is in Dutch for example (no duplicate content). We're now trying to translate every content into two languages. How can I set-up the default language in this case?

November 26, 2018 at 8:06 am #2938754

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi There,

Thanks for contacting WPML support forum.

The default language of the post/page is what is set in WPML-> languages -> Site Languages, Since you already have posts created only in secondary language the posts can be translated to default language following the same procedures for post/page translation.

Choose any of the active languages in WPML-> languages -> Site Languages as the default language, basically this depends on your user base. Default language can also be changed at any point of time, However, make sure it is from your active languages list.

I hope this answers your question

Feel free to write back if you have any further questions


November 26, 2018 at 1:10 pm #2940195


Hi Raja Mohammed,

Thanks for your reply and explanation. I think the settings for me are different since I don't think I can follow-up your steps. Could you assist me so I can follow your advice? I will show you what I see - in the attachment. In WPML 1 you'll see that I can only add a Dutch Translation because every post/page is default in English (but some are already Dutch). In WPML 2 you'll see a Dutch text that is put into 'default English' because of the settings. So, how can I exactly translate the Dutch text to English? Thanks in advance! Roos

November 26, 2018 at 3:36 pm #2940901

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)


It seems like you have wrongly added a Dutch post in default English language.

Please follow the procedure below

1) Translate the post to Dutch by clicking on the plus icon on dutch option (refer image 1.png)
2) Click on “Copy Content from English” in the language box (refer image 2.png)
3) Update the post, You now have moved the Dutch content to Dutch language.
4) Change the language to English from the language drop down in the top bar (refer image 4.png)
5) The post for English language will be available for editing. now you are free to update the content to English and save the post.

Let me know how it goes and feel free to write back if you have any further difficulty