Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 4 voices.

Last updated by John-Pierre Cornelissen 6 months, 4 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 7, 2021 at 11:24 am

John-Pierre Cornelissen

Question, I just translated a website automatically with the ATE. In the settings I have specified that all translation for new and existing content should be done by the ATE.

May 7, 2021 at 12:13 pm
May 7, 2021 at 12:15 pm #8713827

John-Pierre Cornelissen

The problem is, in that form I can only share one set of credentials. So I can't share them for the site I reported this issue for and at the same time for my test website.

So I left the credentials for the actual website with the issue.

May 7, 2021 at 12:16 pm #8713865

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

If you don't see the form below, pelase don't add your credentials as they will be publicly exposed:
hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

May 7, 2021 at 12:25 pm
May 7, 2021 at 8:33 pm #8716841

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. This issue seems to be caused when upgrading WPML in some very specific cases as reported at: https://wpml.org/forums/topic/problems-syncing-advanced-translation-editor-users-with-ams/.

I kindly ask you the access details of your staging website database management tool, so, I can try our recommended workaround in order to fix it. The next reply is marked as private, so, you can safely provide these details. Thank you for your collaboration and patience, have a nice day.

May 7, 2021 at 9:23 pm #8716883

John-Pierre Cornelissen

Hi Marcos,

I already provided the credentials of two sites.

I checked the database of these two site:

hidden link - TEST SITE
WPML_SITE_ID:global 62616436-6636-5464-b934-373836313566
WPML_SITE_ID:ate 62616436-6636-5464-b934-373836313566

The id's of these two sites are exactly the same, but the sync option still generates.
Error: No method error: undefined method `id' for nil:NilClass

--

hidden link - LIVE SITE
WPML_SITE_ID:global 37383265-6237-5662-b665-663861316538
WPML_SITE_ID:ate 38373233-6237-5835-b764-346665623262

The id's on this site are different.

Note that the actual issue on this site is that the two translators don't have access to the ATE. (see attached screen shots)

Also note:
wpml.hrcws.nl holds my main ATE credits.
winketendrinken.nl is connected to use the credits of wpml.hrcws.nl

--

I have a database backup of both sites. You can go ahead and try to fix the issue.

Thanks
JP

roles.jpg
ATE Access.jpg
May 8, 2021 at 8:20 am #8719049

John-Pierre Cornelissen

I just tested on wpml.hrcws.nl

* Created a new user with the editor role
* Made that user a translator
* Then checked in translation management » translation tools » payments & settings »who can use ATE.
* The use I added is not listed there
* And sync translators still doesn't work

Why does WPML keep a specific list of translators who have access to the ATE, if there is absolutely no setting where you can add translators who have access there?

PS: I enabeld the plugin WordFence and InfiniteWP (Horeca Webservice Beheer) again for securitiy reasons and backups.

May 10, 2021 at 8:00 pm #8733029

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I created a Duplicator package of your staging/test website and installed at my localhost in order to test the Synchronize translators and translation managers error, when doing so the issue doesn't happen. I escalated this ticket to our second level support and also sent your questions to them, I will update you here as soon as I have some more details regarding it. Have a nice day.

May 11, 2021 at 9:37 am #8736855

John-Pierre Cornelissen

Thanks.

I have 4 websites that use the ATE:
- 3 give the error when I sync translators.
- 1 site synchronises correctly. When I add a new translator on this website it's automatically added as someone who is allowed to use the ATE.

May 12, 2021 at 9:12 am #8746677

John-Pierre Cornelissen

Hi, any news on this?

I saw someone logged in to my test website yesterday, disabled WordFence and enabled logging again.

What's the outcome?

Just to be sure, you know you are looking at the test website, right? In the end the issue needs to be fixed on the live website I shared in the first private message at May 7, 2021 at 11:24 am ...

Thanks
JP

May 12, 2021 at 2:07 pm #8749561

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello!

The problem should be solved now. for some reason some information on one of the connected sites was missing and it was creating this issue.

We fixed it on our end and now all you need to do is create a new job under WPML > Translation Manager and start using ATE.

Regards.

May 13, 2021 at 1:42 am #8752799

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, let us know if you are able to proceed with the Advanced Translation usage. Thank you for your collaboration, have a nice day.

May 13, 2021 at 9:52 am #8755751

John-Pierre Cornelissen

Yes this is solved now. Thank you for your help.