Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year, 4 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
February 26, 2020 at 8:47 am #5568817

Kristof

Hi,
We have this Avada powered website translated into 4 languages, but every time we need to make some structural changes to the default language, for example, add a textblok or a video or an accordion, we need to add this 4 times.

It would seem more time efficient if we only have 1 "main" template in the default language and do the changes there and then take care of the translations in some WPML editor. So the structure gets determined by the default language.

Is that possible?

February 26, 2020 at 1:05 pm #5571385

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Unfortunately, there's no other way of dealing with this.

That is why it is recommended that you translate a page that was built with a content builder only after you created all the content sections. However, if you do add extra things after you already translated that, you will definitely have to implement the changes into all the translations.

I would have loved to be able to offer you another alternative but we don't have that.

PS: Also, the best steps for translating content in the Avada theme can be found in this link here (https://wpml.org/documentation/theme-compatibility/using-wpml-with-the-avada-theme/) - you might know about it already but I just wanted to share with you.

Kind regards,
Mihai Apetrei

February 26, 2020 at 5:12 pm #5573337

Kristof

1. And if we would duplicate the pages from the default language to the other languages? Would the duplicates pick up the translations or would all languages show the default language then?
2. Would it make a difference if we used the Hello theme and Elementor Pro builder?

February 27, 2020 at 8:35 am #5576479

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

1. All languages would show the default language if you choose to duplicate (practically it would overwrite what's recorded in the database already)

2. No matter what content builder are you using, whenever you create new content in the default language, you will need to translate it in the other languages, too.

From what I see, Avada has global elements that you can create and I guess that you can import them into the translation pages, too.

Now, it really depends on how did you translate the pages.

For example:

1. If you use one of our editors (WPML Advanced Translation Editor or WPML Classic Translation Editor), then, right after you make any change into the default language, your other translations will show up as "needs update" and when you open the translation editor, it should show you the new fields that need to be translated

2. If you created translations by duplicating the content from the default-language and you are using the Fusion Builder (Avada's theme content builder) for example instead of the WPML translation editors, then in that way, you should be able to use global elements - the same thing should happen if you use Elementor for example and you save templates.

I hope that I was able to answer your questions.

Please let me know if there's still something unclear.

Kind regards,
Mihai Apetrei

February 28, 2020 at 12:48 pm #5585195

Kristof

Hi, we are familiar with the Avada Global elements, but we are experiencing some issues which prevent us from using them now.

1/ "Home – Container – Presentation Video" is only Global in Dutch and English (screenshot 1). In French and German, the Global indicator is missing (screenshot 2). This is confirmed by the white background in the Avada builder when we insert that Element, where a Global should be blue.

2/ "Home – Container – 3 pluspunten" is Global and has all translations, but it is missing in English/French/German.

3/ When I edit the translation of an element via the Pencil icon, I always land on the editor of the oldest Element (More info?). This happens in all languages. When I delete "More info?", then the Pencil icons redirects to the editor of Comments pre-container and so on.

4/ When I start deleting the oldest Elements, the Pencil icons suddenly change into Plus icons. When I delete some more, they become Pencils again, and then Plus and then Pencil again (screenshot 3)

If you enable secure chat, I can give you admin logins.

Screenshot_3.jpg
Screenshot_2.jpg
Screenshot_1.jpg
February 28, 2020 at 2:42 pm #5586289

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you write me tonight or this weekend.

Kind regards,
Mihai Apetrei

February 29, 2020 at 12:54 am #5589103

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they work.

I will spend more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

March 2, 2020 at 4:43 pm #5601205

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Point 1:

It seems that the custom field for the "global" feature was set to "not translate" instead of "copy.

I will attach a few screenshots below so that you can see what I did to make the french and german version to be set as GLOBAL, too.

I will also list the steps below:

1. I went to WPML > Settings > Custom fields section > Show system fields > searched for "global" > set it from "not translate" to "copy" and Save
2. Then I went inside the original language (Dutch) Home Container Presentation Video template and I made a small edit, then I added it back and re-saved the template
3. After that, the French and German version were set to Global, too

Point 2:

From what I can see, "Home – Container – 3 pluspunten" shows on the front-end in all languages, however, I can see that in the backend, there's only one place where the edit pencil icon shows up - for this, you would need to open a new ticket.

Practically, for points 2, 3 and 4, we need to have new tickets opened as there are different issues that need to be investigated.

My recommendation though would be for you to first:

1. Create a full website backup
2. Then, disable all the non-WPML plugins (disable any caching plugin and everything that is not WPML-related or theme-related)
3. See if the issue is happening again

My guess is that this might happen due to some incompatibility between WPML and at least one of the plugins that you have active.

Also, from what I can see, you are using old versions of our plugins (hidden link) - I will also attach a screenshot of the WP Admin > Plugins > Add new > Commercial page.

After you do a site backup, you should update everything to the latest version as the issues you are experiencing might be due to the old versions of our plugins that you are using.

I think after following all those steps, things should start getting fixed. If not, please open tickets for each issue separately so that we can concentrate on each of them.

Kind regards,
Mihai

Screenshot 2020-03-02 at 18.41.03.png
Screenshot 2020-03-02 at 18.23.50.png
Screenshot 2020-03-02 at 18.25.54.png
Screenshot 2020-03-02 at 18.26.34.png
Screenshot 2020-03-02 at 18.19.51.png