This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to change default language of text string, particularly for WooCommerce?

Solution: Solution here: https://wpml.org/forums/topic/how-do-i-change-the-default-language/#post-4171751

This topic contains 9 replies, has 2 voices.

Last updated by nxl1107 3 months ago.

Assigned support staff: Noman.

Author Posts
July 3, 2019 at 10:23 am #4134661

nxl1107

Hello,

I want to change base(default language) text.
For example, default language is English and how do i change the english text?
Please check the attachment.

Regards,

July 3, 2019 at 11:51 am #4135587

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. If you want to change default language texts, you must edit the strings directly in the file of your theme/plugin. After edit that string, you need to scan your theme/plugin again.

To do this, first edit the strings in the necessary files. Then click on the WPML >> Theme and plugins localization. Make sure the option "Translate the theme and plugins using WPML's String Translation" is selected.

Scroll down and look for "Strings in the theme". Click on the "Scan the theme for strings" button.

If the strings are in the plugin, scroll down, and look for "Strings in the plugins". Select the correct plugin and at the end of the page, click on the "Scan the selected plugins for strings" button.

Then again in WPML >> String Translation, you can translate the new string.

Thank you

July 9, 2019 at 6:44 am #4167773

nxl1107

Hello,
Sorry i'm late reply!

I mean i want to change this language(please check the attachment).

Should i change po file of WooCommerse directly?

July 9, 2019 at 2:19 pm #4171751

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Here is an easy workaround to modify theme/plugin default strings without modifying core files:

- Go to WPML >> String Translation and find the string you want to edit in the default language.

- Select it and click on "change selected strings language" option from dropdown and change the language to any "dummy" language that you will not use in the current site.

- Now you should be able to see the option to "translate" it in the original language.

- Please uncheck ‘Assume that the original language of all strings is English’ checkbox from WPML >> Theme and plugins localization > Localization options section as you can see in the attached screenshot.

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 10, 2019 at 9:27 am #4177759

nxl1107

Hello,
Thank you for message.

>Select it and click on "change selected strings language" option from dropdown
I did not find this dropdown;(
Can you send the screenshot to me?

>Please uncheck ‘Assume that the original language of all strings is English’ checkbox
I do not check this checkbox(please check the attachment file)

Regards,

July 10, 2019 at 12:18 pm #4180049

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

> I did not find this dropdown.
Attaching.

> I do not check this checkbox.
Fine then.

Thank you

July 10, 2019 at 12:46 pm #4180381

nxl1107

 

July 10, 2019 at 12:52 pm #4180401

nxl1107

Sorry i made a mistake!
My issue is resolved now. Thank you!

July 15, 2019 at 2:01 pm #4211943

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

[ ticket status changed ]

July 15, 2019 at 2:49 pm #4212365

nxl1107

My issue is resolved now. Thank you!