We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by laura-dY 6 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 19, 2019 at 1:01 pm #3645843

laura-dY

I've created a custom post type: experts. Within this CPT, I have many custom fields using ACF. I had set the fields first_name and last_name not to translate, but I should have set it to copy. I've changed that now, but the fields don't show up when I edit a translation and they don't show up on the front end. How can I get these new settings to apply? Do I have to go into every expert post and add those fields manually?

April 19, 2019 at 1:30 pm #3646079

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

You would need to save both the original language post and the translation, too. If you don't save the original, the "copy" command is not triggered.

Hope this is helpful 🙂

Kind regards,
Mihai Apetrei

April 19, 2019 at 1:43 pm #3646139

laura-dY

Ok, so re-saving the default language version isn't enough to copy the fields over? I have to go in and manually save every post in both languages?

Also, these fields won't show up in the translation screen correct? Only fields set to translate will show up there? (I thought they might show up but not be editable).

Thanks!

April 19, 2019 at 4:00 pm #3647391

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Ok, so re-saving the default language version isn't enough to copy the fields over? I have to go in and manually save every post in both languages?
- Yes, you are right!

Also, these fields won't show up in the translation screen correct? Only fields set to translate will show up there?
- Yes, you are right. Selecting "Copy" should copy the custom field and keep it in synchronization with the default language content while using "Copy once" would just copy the custom field only once but then it would allow you to change the content

You can see it explained here, too (at the bottom):
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

I hope that you will find this information helpful 🙂

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you need more help with this.

Kind regards,
Mihai

April 23, 2019 at 6:49 am #3659805

laura-dY

My issue is resolved now. Thank you!