This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The language switcher short code is on page 1. We need to pass the selected language_code in the url along with the parameters (key1, key2, key3, key4) being passed to page 2. Screen shot #2 Page 2 illustrates the problem we are having. The language_code is passed, but the parameters are not.

Solution: I understand that you need to pass the parameters (key1, key2, key3, key4) in the URL to the other language. If this is correct, then you can do this by following this steps: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 week, 1 day ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 8, 2019 at 12:39 pm #4715187

loriB-3

Our question is, how is the selected translation stored, passed, retained throughout the site? Folders has been selected. Is there a better way to set it up to help us achieve what we want? Retention of the selected language throughout the site?

Thank you.

October 9, 2019 at 1:14 pm #4723287

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I'm truly sorry but I don't understand the issue 🙁

Can you please elaborate a little more so I can better understand?

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

October 10, 2019 at 12:49 am #4725963

loriB-3

The language switcher short code is on page 1. We need to pass the selected language_code in the url along with the parameters (key1, key2, key3, key4) being passed to page 2. Screen shot #2 Page 2 illustrates the problem we are having. The language_code is passed, but the parameters are not. The url is passed via the Submit button on Page 1 emails & actions as follows: hidden link{field:firstname_1569013575057}&key2={field:lastname_1569013577136}&key3={field:email_1526653801502}&key4={field:listcountry_1569013581410}
It needs to be: hidden link{field:firstname_1569013575057}&key2={field:lastname_1569013577136}&key3={field:email_1526653801502}&key4={field:listcountry_1569013581410}

October 10, 2019 at 9:05 am #4728619

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I understand that you need to pass the parameters (key1, key2, key3, key4) in the URL to the other language. If this is correct, then you can do this by following this steps: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#preserving-url-parameters

Please let me know if the documentation above solved the issue?
Regards,
Carlos

October 11, 2019 at 6:32 pm #4740781

loriB-3

My issue is resolved now. Thank you!

October 14, 2019 at 9:22 am #4748447

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos