This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 14, 2018 at 1:11 pm #2735440

joopv-2

Tell us what you are trying to do?

I'm at a loss here, though I expect it to be some simple misunderstanding of my part. I'm using AVADA (theme) and several plugins. Among them Participants Database and Event Calender.

What I don't get is that Event Calender automatically shows all their text in the right language (German & Dutch). The Avada Theme shows English texts everywhere, e.g. with Posts it speaks of 'Author', 'Next' 'Previous' etc. Although these terms may come from WP itself.

But Avada and WP come in several languages. Why would I have to translate every string in WPML when these translations are there? I can often see suggested translations in String translation that are 100% OK.

The same goes for Partipants Database. The plugin is installed in perfect German, but everywhere on the site the txts are in English.

What am I overlooking or doing wrong?

You're help is very much appreciated.

See hidden link home page for participants database (search field). The text in the search I can control (Suchen/Zoeken) but the buttons are in English.

Then please have a look at the pages 'Events' (perfect translations in German and Dutch) and Posts (all general texts are in English.

I will be happy to give you a login over a secure communication channel.

Is there any documentation that you are following? Yes, the help files

Is there a similar example that we can see? See above

What is the link to your site? See above

September 17, 2018 at 5:43 am #2739690

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Looking at your debug information, I can see that you are not using "Don't use String Translation to translate themes and plugins" in theme localization options, which means that all the translation will be handled using .po/.mo files.

Could you please go to /wp-content/languages/ folder and see if the themes/plugins .mo/.po files are there, if not could you please add the .mo/.po files correctly there, this should fix the issue.

Look forward to your reply.

Thanks

September 17, 2018 at 11:08 am #2740674

joopv-2

Thank you! I thought it had something to do with these settings. I added a screenshot of these settings, as they are now. What should they be, if I won't to use the translations that exest of the plugins and theme?

I checked the /wp-content/languages/ folder and the .mo and .po files are there!

September 18, 2018 at 7:59 am #2743926

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The settings seem to be Ok if you are trying to only use the .mo/.po files, but if you want to use .mo/.po files for existing strings and use string translation to translate the untranslated strings you can choose the "Translate themes & plugins using the string translation but load .mo file as the backup"

Since you mentioned the .mo/.po files are there and still not working, to further debug this issue, I would need to check your language folder and some site settings. I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

September 19, 2018 at 1:42 pm #2748964

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I checked your wp-content/languages/themes folder and couldn't see any related .mo/.po files for the themes, could you please add the theme .mo//po files for the correct languages there to solve the issue?

Let me know if this helps.

Thanks

September 19, 2018 at 2:15 pm #2749027

joopv-2

I'm affraid you're right. There is only a Danish language file for Participants Database. I'm sorry I overlooked. I will research and get back to you.

In the mean time I changed the setting to "Translate themes & plugins using the string translation but load .mo file as the backup" and translated a Widget, but the translation doesn't show up (it's the footer with the logos on every page, above the copyright message). Any clue?

September 20, 2018 at 3:10 am #2750665

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The same string is registered twice with different names and it seems you add the translation on the wrong one, could you please translate the string from "Widgets domain" and name ==> "widget body - text_icl-3" to translate it correctly.

Thanks

September 20, 2018 at 10:05 am #2751702

joopv-2

Thank you! That helped! Wg=hat I don't understand is: you say the .mo and .po files are missing but how can it be then that in the WP Deshboard these apps are in German or Dutch and that I see the correct translation in String Translation (greyed out) but cannot copy it into the traslation field. These translations have to be 'somewhere'?

This is just my lack of knwowledge about how translations work in WP. I'm sorry.

Will come back to you when I found the correct .po or .mo files.

September 20, 2018 at 2:27 pm #2752460

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

 that I see the correct translation in String Translation (greyed out)

Could you please attach a screenshot to show examples, so I can provide you an detailed information?

Look forward to your reply.

Thanks

The topic ‘[Closed] How to activate the Theme and Plugin translations’ is closed to new replies.