Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by John-Pierre Cornelissen 2 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
March 16, 2021 at 6:39 pm #8325079

John-Pierre Cornelissen

Hi,

I have canceled all translation jobs under Translation Management » Translation jobs.

But if I go to Translation Management » Translation Tools, all these jobs are still listed with the status 'Ready to be translated'.

How can I fix this?

Thanks
JP

March 17, 2021 at 11:08 am #8330847

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hi there!

There is no way to cancel the jobs from over there, because this procedure here is different from the WPML > Translations.

See, when you cancela a job you're just preventing a translator to translate that page, BUT bulk translation is executed by translation managers which always have access to the pages.

If you want to see them as cancelled, i'd suggest that you ask for this feature here: https://wpml.org/suggest-a-new-feature-for-wpml/

Regards.

March 17, 2021 at 11:58 am #8331543

John-Pierre Cornelissen

Hi and thanks.

If I can't cancel them, then how do I fix the incorrect word count.

See, these are WooCommerce products. A product has 824 words, but most products have almost the same text, only 109 words are unique.

From the Translation Tools menu, I automatically translated a single product with 824 Words.
Another product in the translation tools also counts for 824 words.
But if I submit that product again it counts 109 words.

So that same product exists twice in the translation tools menu:
8362586 Rubio Monocoat Oil Plus 2C AQUA - Duoblik 350ml (SET A+B)post_product nl - en DeepL 824 2472 Ready to be translated Mar 16, 2021
8378139 Rubio Monocoat Oil Plus 2C AQUA - Duoblik 350ml (SET A+B)post_product nl - en DeepL 109 327 Ready to be translated Mar 17, 2021

The problem is that the advanced translation editor counts the number of Words that are listed in the Translation tools menu, and uses that to see how much credits I need. Before I can continue, it wants me to buy 7 times more credits then I really need.

Thanks
JP

March 17, 2021 at 1:44 pm #8332951

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Can you please give me a more specific example? maybe the word count will appear to be higher but it will still not use as many credits since the credits are used in ATE itself and it will still count the content that is already in the translation memory.

I'd like to test this on your site with a few products if you please tell me which ones i can test with.

I'll return all the credits that i'll use during my test, so it's a win-win situation for you and i'll be able to confirm what i just said, would this work for you?

March 17, 2021 at 1:44 pm #8332955

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Oh, of course, i'd need access to the site, if that's possible as well (i have enabled the credential fields for you)

March 17, 2021 at 3:40 pm #8334707

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I asked our develpers if they could do something about this and it will be fixed, the cancelled jobs will appeared cancelled so they can't be translated.

In the meantime, filter the jobs by dates, so you can find the latest jobs.

This what you can do:

- Cancel all the jobs
- Resend them through WPML > Translation Management > Translation dashboard
- Now go to translation tools > Bulk Automatic translation and filter by today's date in both datepicker fields
- Now translate them using the right amount of credits.

I have also credited the credits i used and an extra that our team allowed me to give you for this scenario disocvery which will allow us to improve our system.

March 17, 2021 at 4:17 pm #8335143

John-Pierre Cornelissen

That's great, thank you for your help!

Will they also fix the problem that documents that are translated through here will use the translation memory? Because the document I translated twice also calculated credit usage for the second auto translation.

March 18, 2021 at 9:28 am #8339887

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I'm not sure what you mean by

Will they also fix the problem that documents that are translated through here will use the translation memory?

Could you please expand on this, because i'm not entirely sure what you mean.

March 18, 2021 at 9:56 am #8340183

John-Pierre Cornelissen

Hi, what I explained before

Rubio Monocoat Oil Plus 2C AQUA - Duoblik 350ml (SET A+B)

The original job was:

ID 8362586 it counts 824 words and 2472 credits with DeepL.

After translating another similar product, I submitted this product again but with

ID 8378139 it counts 109 words and 327 credits with DeepL.

So I let it translate ID 8378139 and the products is now correctly translated.

If you now look at the translation tools tab, the job with ID 8362586 for the same is still there, even though it was already translated. If I continue to translate this one, it says it needs 2472 credits. That's incorrect, it would only need 327 credits, and since it is already translated it doesn't need any credits anymore.

I then went ahead and sent job 8362586 for automatic translation. I was hoping/expecting that it wouldn't use any credits, because that product was already fully translated from job ID 8378139.

In stead, it did calculated 2472 credits, while it shouldn't have calculated anything because of the translation memory. See also the attached image with the usage report.

So basically, yesterday I translated everything as per your instructions. In the translation tools tab there are still the old jobs with the high word counts from march 16. If I would submit them for translation, it uses the calculated number of credits, even though everything has already been translated and in translation memory.

Thanks
JP

March 18, 2021 at 10:02 am #8340221

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Ah, i see, sorry i thought it was something extra. yes, that is still part of the issue so it should be fixed as well 🙂

March 18, 2021 at 10:11 am #8340369

John-Pierre Cornelissen

My issue is resolved now. Thank you!

September 11, 2021 at 3:55 pm #9568865

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Just FYI: we made a lot of progress with ATE and how it works in WPML and you'll see the changes in WPML 4.5 which you can already test (beta 2 alreasy has most of the changes and the jobs under bulk automatic translation are all "cleaned out" now)

Regards.

September 13, 2021 at 8:07 am #9574053

John-Pierre Cornelissen

Thank you for the update Alejandro!