This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Radu 4 weeks ago.

Assigned support staff: Radu.

Author Posts
August 13, 2019 at 4:06 pm #4389389

jan-willemv-9

Tell us what you are trying to do?
To change the default language from en-GB to en-GB, this because the theme we are using SoHo-Hotel advises to change 'quirky text' in their theme to 'sound text' by editing the po.file and translate en-GB to en-GB.

WPML only alouds to change default language if the site is SSL (https) secured, but this is a site under construction, to replace an exiting site.
Hosted by SiteGround they only apply SSL after the site go 'live'. We can only go 'live' if the site is finnished.
So here is a bit of a problem. I can find a work arround in the documentation provide by WPML for this problem. Or your documentiation need to be update.
Sorry to trouble you with this, and yes I can't think of it that the answer would take you more as 30 minutes. If you can solve in 30 minute that would be lovely, but probably it takes you less time. My is it nagging for two days now, due to delayed time difference of primium support, finding a solution to this. Hugg to every body of the support team for their harsh work.

So the question is how to solve this to make the new en-GB Soho-booking plugin po.file the default folder?(sohohotel_booking-en_GB.po-- Soho Hotel Booking) Please help us out.

Is there any documentation that you are following?
Documentation of SoHo Hotel Theme, WordPress and WPML

Is there a similar example that we can see?
No, not that I know of.

What is the link to your site?
hidden link

With love to you all,
Rita and Jan-Willem

August 14, 2019 at 8:07 am #4393087

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan,

Thank you for reaching out the WPML support!

Can you tell me how do you want to change the language from en-GB to en-GB, please? I mean, it's the same language and this is the part that I don't understand. What's the actual change here? Can you tell me what do you mean by quirky text and sound text too, please?

Also, you should be able to use the Different languages in directories option, even if you don't have SSL on the staging website. Can you try to disable the Use directory for default language option and tell me if there's any difference, please?

Thanks,
Radu

August 14, 2019 at 10:11 am #4394069

jan-willemv-9

Hey Radu,
in the SoHo Hotel booking plugin are some text that are dysfunctional and stupidly made by the builders. Following their instructions, we edit the po-file of the SoHo-Booking plugin: en-GB to en-GB with better text. Now this new en-GB po-file needs to become the default text. The editing of the former po-file is done according to instructions of SoHo Hotel support in PoEdit.
The problem is everything works fine until we reactivate WPML-plugins to make furthur translations to Dutch, Frensh and German. As explained WPML prohibits to change the default language, see screenshot! As explained so we disabled the WPML-plugins.

If I have to follow your instructions you have to be more specific what I as a first-time user of WPML have to do. So do I first have to reactivate WPML, which part of which specific WPML plugin? Where can I disable: the Use directory for default language option? and how can I tell if any difference occurs, please? Your instruction is not clear enough to me. Please send a screenshot or more step by step explanation along with your answer.

Thanks for your support,
Jan

August 16, 2019 at 11:14 am #4405989

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan,

This time I understood what you changed on your website and what are you trying to do now when using WPML. In this case, can you activate back the WPML plugin (and its add-ons), and then go to Dashboard → WPML → String translation, scroll down, and import the PO file that you created, please? This way, the new strings should be added to your website.

Now, going back to the Language URL format, this is the first time to see this error appearing. Can you tell me if that red message still appears if you try to select the Language name added as a parameter option, please? I want to narrow down the option that might be causing this issue.

Thanks,
Radu

August 16, 2019 at 5:10 pm #4407691

jan-willemv-9

Hey Radu, well I did exactly what you recommended. So then it seemed to work because the text was changed, but then the whole booking-plugin broke down and stopped to show available rooms, and only showed one, instead of four. So now I recontacted the support desk of the theme. Something went wrong and I am left with the broken pieces...

Hope we find a way to fix this.... Keep you posted.

Jan-Willem

August 17, 2019 at 7:22 am #4409497

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan-Willem,

Please keep me posted about the progress you're making on this once you work together with the theme authors. I'm right here if there anything else I can help you on this topic.

Thanks,
Radu

August 17, 2019 at 3:50 pm #4410375

jan-willemv-9

Hello Radu,
The WPML influence on the SOHO Hotel Theme is still not solved!

Again I deactivated WPML and everything works and looks fine in the theme.

The developer says the theme is WPML prepared, but when I activate the WPML plugins things starts to go wrong? Maybe this is because I am a newbie in WPML and the description in the documentation is to compact for me to get the right idea about what I should or should not do.

For instance, how do I make sure the "shb_booking" post type is set to not translate?

I see lots and lots of check-boxes, but how to decide which presets are the right one?
Which preset to change? Isn't there a preset to activate with this theme SoHo Hotel, so everything just goes smoothly and automated? Please help?

Thanks for your quick reply,

Jan-Willem

August 19, 2019 at 11:11 am #4415459

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan-Willem,

If you want to make sure that shb_booking will not be translated, all you have to do is go to Dashboard → WPML → Settings → Post Types Translation, look for shb_booking, and select the last column option (Not translatable). Once you save the changes, the shb_booking post type will no longer be translatable.

Can you give me a few more details about the check-boxes that you're talking about, please? There are a lot of options across the website and it's hard to know which is the one that you're asking about.

Also, what is not working smoothly and automated? I want to help you use the WPML plugin and make your website be multi-language but I need a few more details about the parts that you need help with, in order to point you to the right changes.

Thanks,
Radu

August 19, 2019 at 2:20 pm #4416823

jan-willemv-9

Hey Radu,
Well, I think I can better buy a ticket on Ryan Air as getting through all the check-boxes in the setting page of WPML because there is no information about the effect of the choices. So, for instance, this (see attached file). Which choices to make and why? We had this problem setting the default language to en-GB. It looks this problem has solved itself but with reactivating WPML, I get this question again. So what to do? Do I need to compose a path, and if yes how should it be composed? please clarify. Do I need to fill this in? Maybe you have more handy tips? BTW our URL has changed to bnb-tilburg.nl.
Thanks again...

August 21, 2019 at 11:54 am #4431029

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan-Willem,

I really hope that you don't have nightmares with WPML. We want you to create the translation fast and easy. However, sometimes, things are a bit complicated, depending on the theme and plugins that you're using.

I'm glad you started working on the translation of the homepage. I wanted to have a look at what you did so far but it seems that the password you send to me on the previous message is not working. Can you check it and send me the credentials again, please? I'm sure that we'll be able to sort things out and get you back on track in no time.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 21, 2019 at 12:12 pm #4431139

jan-willemv-9

Hi Radu,

Well maybe you misinterpreted the password, it is 25Z[zero]nneBl[zero]emen:
which results in 25Z0nneBl0emen. Please try again?

Thanks,
Jan-Willem

August 21, 2019 at 12:27 pm #4431283

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Jan-Willem,

I'm just using copy/paste for both the credentials (I'm not manually using them) so this is not the issue. I tried again to use the password you send to me but with no luck. Can you try to generate a new password for the wpmlsupport and send it to me, please?

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

August 22, 2019 at 6:49 am #4436905

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey,

Here's an article where you can find some more details about the root page: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#what-is-a-root-page-and-do-i-need-one. Basically, you can create a index.html page, and add it to the public_html folder (through FTP). This way, when a visitor is accessing your website without the language part (like hidden link), the root page will be displayed.

Now, going back to the Dutch homepage (hidden link): now the layout should be back to normal. Regarding the parts that are not translated, could you edit again the Dutch translation, add the translation for all the elements (until the progress from the bottom side reaches 100%), and tell me how things look this time, please? I'm pretty sure that everything will be fine this time.

Thanks,
Radu

The topic ‘[Closed] How to change the default language po-file from en-GB to (NEW) en-GB’ is closed to new replies.