Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.51 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by francescoL-19 2 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
May 30, 2020 at 9:53 pm #6257353

francescoL-19

Hello,

I use Elementor as page builder.
When I use whte text, in the WPML editor it's very difficult to read th etext.
I would like to change:

the white color in middle gray
the light gray in a dark gray

I tried to find the right CSS, but I wasn't able.

Thank you.

May 31, 2020 at 6:26 am #6258329

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

By default, the text color in the translation editor is black as the attached image. not grey.
A plugin style or theme style should be overriding it in your case.

If you disable all the plugins except WPML do you see the same issue?
If you switch the theme to a default theme like twenty seventeen, do you see the same issue?

Please check and let me know.

Regards,
Riffaz.

May 31, 2020 at 5:30 pm #6261237

francescoL-19

Hi Riffaz,

sorry, I didn't give you all information.
Yes I use Elementor and I changed the color of the text.
That's why the text is "almost white".

But, many website use bright text. And, use 100% white and light green is not the best solution.
I think you should add the possibility to change the editor background color.
In the meantime, how can I change it via CSS?
I tried but, with no luck.

Can you help me?

June 1, 2020 at 11:35 am #6264993

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Add this code to the bottom of your functions.php

add_action('admin_head', 'cte_font_custom_color'); 
function cte_font_custom_color() {
  echo '<style>
  .wpml-dialog-translate .wpml-form-row input:not([type="submit"]):not([type="button"]):not([type="checkbox"]):not([type="radio"]) { color: #000 !important; }
  </style>';
}

Change the color code to the color you want.
This will fix you issue.

It would be a cool feature though.
Please send a feature request for this: https://wpml.org/suggest-a-new-feature-for-wpml/

Regards,

June 2, 2020 at 12:28 pm #6273953

francescoL-19

Hello Riffaz,

I did the request. We will see! Thank you!

June 2, 2020 at 1:26 pm #6274587

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Great!

Please close this ticket and do not hesitate to open new tickets if you have more questions.

Regards,

June 2, 2020 at 1:29 pm #6274619

francescoL-19

My issue is resolved now. Thank you!