Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by jin woo 5 years, 2 months ago.

Assigned support staff: Ahmed Mohammed.

Author Posts
September 11, 2014 at 4:19 pm #468869

jin woo

I am trying to: Make translated for custom fields.

I have attached 4 pictures.

We have custom fields which admin can setup custom fields.
"Label", "text", "dropdown", "textarea"

please have a look at my attach file ( custom-fields-setting.png )
This is how admin can set up the custom fields.

========

And it shows "front-end from" (custom-fields-front2.png) which our site users can fill them out.

it is also possible to use on Back end (custom-fields-backend.PNG).

=========

After users fill them out, it shows on the detail page. single-custom-post.php (custom-fields-result.PNG)

This is how we use custom fields. but the problem is how to make it possible to translated with WPML.

As you see "Additional information" and "Mon", "Tues", "Wed", "Tues", "Fri", "Sat", "Sun"...
These are all what you (admin) can modify or customize.. at the same time it has to be another languages.

How can I make it to work with WPML to be translated to another languages?

Thank you for your time.

September 12, 2014 at 10:09 am #469489

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+01:00)

Thanks for contacting us, I'll help in this.

Can you please go to your WordPress dashboard -> WPML -> Translation Management -> Multilingual Content Setup -> Custom fields translation. If you're able to see those custom fields, then you need to mark them to "Translate".

If you're not seeing them, please tell me more info about those custom fields and how did you create them.

Thanks!

September 12, 2014 at 11:13 am #469549

jin woo

Hello Ahmed,

Thank you for your support,
but it doesn't show up. I can't even find the option_name (jav0_themes_settings)
it's in wp-option >> jav0_themes_settings. (serialized)

is there any way to do? we have 1 more customization fileds and they are also in the same serialization.

have a look at attached file.

Thank you 🙂
Rob

September 12, 2014 at 12:02 pm #469601

jin woo

I have found that... I need to create a config file for wp_option : serialized values.


s:17:"javv_custom_label";a:5:{s:5:"about";s:8:"About Us";s:8:"location";s:8:"Location";s:6:"events";s:6:"Events";s:7:"ratings";s:7:"Ratings";s:7:"reviews";s:7:"Reviews";}s:21:"single_top_map_street";s:8:"disabled";s:13:"topmap_height";s:3:"800";s:31:"single_page_menu_other_bg_color";s:3:"use";s:25:"single_page_menu_bg_color";s:7:"#dd3333";s:27:"single_page_menu_text_color";s:7:"#000000";s:16:"single_item_logo";s:81:"<em><u>hidden link</u></em>";s:13:"field_caption";s:38:"Additional Information (Custom fields)";s:12:"custom_field";a:7:{s:34:"id492f0e06e7e2381e195ce3f85fa42fb8";a:5:{s:4:"name";s:34:"id492f0e06e7e2381e195ce3f85fa42fb8";s:5:"label";s:3:"Mon";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"idd58640b2fb7976f6e55c64f2e10d887c";a:5:{s:4:"name";s:34:"idd58640b2fb7976f6e55c64f2e10d887c";s:5:"label";s:4:"Tues";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"id55ac4c35c6a80a91993b54b1f08cbc80";a:5:{s:4:"name";s:34:"id55ac4c35c6a80a91993b54b1f08cbc80";s:5:"label";s:3:"Wed";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"id617f3c1e85bbb823b9cbc34d94542581";a:5:{s:4:"name";s:34:"id617f3c1e85bbb823b9cbc34d94542581";s:5:"label";s:4:"Tues";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"idaf0e0394cab6cfcd7eaa000c32e0fc6d";a:5:{s:4:"name";s:34:"idaf0e0394cab6cfcd7eaa000c32e0fc6d";s:5:"label";s:3:"Fri";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"ida3b1fa7e05d4df4616c85bd95c103655";a:5:{s:4:"name";s:34:"ida3b1fa7e05d4df4616c85bd95c103655";s:5:"label";s:3:"Sat";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}s:34:"id7ee97797e137413e9e90e01fc04f88fa";a:5:{s:4:"name";s:34:"id7ee97797e137413e9e90e01fc04f88fa";s:5:"label";s:3:"Sun";s:4:"type";s:4:"text";s:5:"value";s:0:"";s:3:"css";s:0:"";}}s:12:"rating_count";s:1:"1";s:12:"rating_field";a:4:{i:0;s:7:"Service";i:1;s:8:"Location";i:2;s:7:"Quality";i:3;s:6:"Others";}

and created config file added this..

<wpml-config>
    <admin-texts>
        <key name='javv_themes_settings'>
            <key name='javv_custom_label' />
            <key name='field_caption' />
            <key name='custom_field' />
        </key>
    </admin-texts>
</wpml-config>

But I can't find any strings. did I miss anything?

September 12, 2014 at 2:03 pm #469746

Ahmed Mohammed
Supporter

Timezone: Europe/Rome (GMT+01:00)

Yeah, you're right. You need to create wpml-config.xml file and place it in the root folder of your theme.

Please refer to this doc http://wpml.org/documentation/support/language-configuration-files/ and you need to create something like

<wpml-config>
<custom-fields>
 <custom-field action="copy">quantity</custom-field>
 <custom-field action="translate">custom-title</custom-field>
 <custom-field action="copy">weight</custom-field>
 <custom-field action="translate">custom-description</custom-field>
 <custom-field action="ignore">date-added</custom-field>
</custom-fields>
</wpml-config>

Please note the "copy" ,"translate" and "ignore" actions.

Please let me know if that helps!

October 9, 2014 at 1:43 pm #489248

jin woo

Thank you resolved.