This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Finally, after very long (and complex) development, ICanLocalize clients can upgrade WPML to its current version and continue to enjoy a streamlined translation workflow.

Problem :

It wasn't possible to use ICanLocalize translation service with the WPML greater than 3.2, if you have done some translation through the service already.

Solution :

Read carefully this article : https://wpml.org/2015/09/migration-for-icanlocalize-clients-to-wpml-3-2-x/

Just to summarize about how to Update to the Current WPML Version :

1. Take a backup 2. Deactivate and remove an old version of WPML plugins 3. Download the newest ones from here : https://wpml.org/account/downloads/ 4. Install and activate the latest WPML plugins (WPML 3.2.7, WPML ST 2.2.6, WPML TM 2.0.5) 5. Download plugin "Migrate ICanLocalize Translation to WPML 3.2" : https://wpml.org/download/migrate-icanlocalize-translation-to-wpml-3-2/ 6. Install and activate it. 7. Go to the new menu that the plugin created for the migration process WPML->Migrate ICanLocalize Translation to WPML 3.2 8. You will see two buttons. First, click to migrate the account to WPML 3.2. This runs almost instantly. Then, click to migrate the jobs. 9. You no longer need the migration plugin. Go to Plugins and deactivate it.

If there are any problems in this migration process (there should not be), the migration plugin will report them on the screen. Create a new ticket in WPML technical support forum, copy what you see and paste in the forum thread. Be sure to explain what you are doing and what you are seeing.

This topic contains 218 replies, has 59 voices.

Last updated by Andrey 3 years, 11 months ago.

Assigned support staff: Andrey.

Author Posts
March 6, 2015 at 10:44 am #572353

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

*************************************************************
IMPORTANT! The instructions below no longer apply. It is now possible for ICanLocalize clients to use WPML > 3.2 Please follow carefully the update instructions provided here: https://wpml.org/2015/09/migration-for-icanlocalize-clients-to-wpml-3-2-x/

*************************************************************

You most likely saw an admin message saying "Your website is configured to connect to ICanLocalize.

This version of WPML cannot be used in this case and it will be not functional until you downgrade or update, once available, to a version which is compatible."

This is not because we don't want you to use WPML 3.2 and it has nothing to do with your WPML subscription.

WPML 3.2 comes with<a href="/?p=516215"> more options for professional translation </a>and this brings with it major changes in the code. These changes affect how WPML communicates with your ICanLocalize account.

As an ICanLocalize customer you may have previous jobs sent to ICanLocalize. There is a possibility that updating to 3.2 could lose this data.

We do not like taking unnecessary risks. More testing needs to be performed to be sure this will not happen.

Exactly because we do not want you to risk losing your ICanLocalize projects we would like to encourage you to temporarily downgrade WPML and any of it's add-on modules you have active.

Of course, once we have thoroughly tested migrating sites with ICanLocalize connection to 3.2 you will be able to use the new version.

How to downgrade WPML

To downgrade WPML 3.2 to 3.1.8.6 or 3.1.9 please follow these steps:

1) Backup your database. You may use a plugin for this if you like such as the Duplicator plugin:https://wordpress.org/plugins/duplicator/

2) Leave a comment in this thread asking for assistance in downgrading. Be sure to state that you have already created a database backup and a support moderator will assist you with the next step of downgrading.

March 10, 2015 at 3:33 pm #574734

quentinV

Hello,
I have just updated wpml and my wordpress theme. Most of the images of my website are no longer displayed and I don't know which one is responsible for this bug. This is why I would like to downgrade my wpml and theme in the hope to get this fixed. Could you help me do that? I have already made a backup of my database and wordpress files.
Thank you

March 10, 2015 at 5:06 pm #574892

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@quentinv, I need to request temporary access (wp-admin and FTP) to your site – where the problem has been replicated – in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

March 10, 2015 at 5:22 pm #574914

samuelK

Can I get one version older of the plugin please? I am getting a constant error since upgrading this morning:

Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 130968 bytes) in /home/content/p3pnexwpnas06_data02/18/2349818/html/wp-content/plugins/sitepress-multilingual-cms/inc/absolute-links/absolute-links.class.php on line 433

hidden link

I am going to disable the plugin now. The moment I do it works fine.

March 10, 2015 at 7:25 pm #575064

quentinV

Hi, I just changed something in the CSS and now my site works fine. I think my problem came from the upgrade of the theme. Thank you for your help.

March 10, 2015 at 8:35 pm #575125

cintiaS

Hi there – I am also having problems since upgrading right now. The pages aren't loading anymore... only the titles appear, everything else is blank. It's taking forever to update a page content via the Quick Edit tool...! What could have happened? Do I need to downgrade?

My site: hidden link

March 11, 2015 at 4:53 am #575250

nyemchynV

I have similar problem - after last security update pages not possible to edit, some pages have 404 error - page not found. Deactivating plungin fixes this. Downgrading did not help, since after downgrade translations do not work. Website: hidden link

March 11, 2015 at 7:18 am #575296

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello all,

Please allow me to kindly point to the title of this thread and remind everyone that this is only for downgrading requests for clients that are using WPML 3.2.

Let me repeat that.

If you have upgrading issues to any other version or are trying to upgrade to any version, this is not the best place to get help. You will get better assistance if you open a new support forum thread.

So with that in mind, may I kindly request that samuelK, cintiaS, nyemchynV to open your own separate threads for your issues?

Thank you in advance for your cooperation with this!

March 27, 2015 at 4:43 pm #589543

Josep

Hi!
I need help for downgrade from 3.2beta to 3.1.9.4.
I've done backup of files and DB.
My ticket is https://wpml.org/es/forums/topic/problemas-con-los-menus-y-los-idiomas/

Thanks!

March 30, 2015 at 8:57 am #590295

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@josep, I need to request temporary access (wp-admin and FTP) to your site. You will find the needed fields for this below the comment area.

April 1, 2015 at 1:25 pm #592172

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@josep, I have made the downgrade. In order to ensure that your new question gets the attention it deserves, please open a separate ticket detailing your issue.

April 3, 2015 at 5:20 pm #593664

e2O

It would be good if we can have a button inside the WPML to downgrade or given us the instructions, thx
this is our site hidden link

April 6, 2015 at 2:10 pm #594274

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

We can't give instructions, because each case might be different. Once a version 3.2 will be announced this post no longer will exist as would be no sense to downgrade the version.

@e2o Do you need help to downgrade ?

April 14, 2015 at 5:57 pm #599390

Emmanuel

Hi,

We tried beta pack (3.2RC2) due to problems with stable versions it seems that we should try to downgrade WPML to 3.1.9.5 as some bugs are now resolved with GavityForms multilingual. Simple question : why 3.2 RC2 do not resolve some bugs that are resolved in 3.1.9.5??? I don't understand...

What's the procedure? Can i do it myself ?

thanks.

Best,

jérôme

April 16, 2015 at 2:57 pm #600858

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@emmanuel, As far as I can see 3.1.9.5 was after 3.2 RC2. The next stable version or beta of version 3.2 should include all fixes which were made before.

Unfortunately, I can't give you any procedure as I mentioned before each case can be different from other.

I set a next reply as a private reply for you. You may want to enclose the access credentials and I will able to help you with the downgrading.