Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 4.57 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Finally, after very long (and complex) development, ICanLocalize clients can upgrade WPML to its current version and continue to enjoy a streamlined translation workflow.

Problem :

It wasn't possible to use ICanLocalize translation service with the WPML greater than 3.2, if you have done some translation through the service already.

Solution :

Read carefully this article : https://wpml.org/2015/09/migration-for-icanlocalize-clients-to-wpml-3-2-x/

Just to summarize about how to Update to the Current WPML Version :

1. Take a backup 2. Deactivate and remove an old version of WPML plugins 3. Download the newest ones from here : https://wpml.org/account/downloads/ 4. Install and activate the latest WPML plugins (WPML 3.2.7, WPML ST 2.2.6, WPML TM 2.0.5) 5. Download plugin "Migrate ICanLocalize Translation to WPML 3.2" : https://wpml.org/download/migrate-icanlocalize-translation-to-wpml-3-2/ 6. Install and activate it. 7. Go to the new menu that the plugin created for the migration process WPML->Migrate ICanLocalize Translation to WPML 3.2 8. You will see two buttons. First, click to migrate the account to WPML 3.2. This runs almost instantly. Then, click to migrate the jobs. 9. You no longer need the migration plugin. Go to Plugins and deactivate it.

If there are any problems in this migration process (there should not be), the migration plugin will report them on the screen. Create a new ticket in WPML technical support forum, copy what you see and paste in the forum thread. Be sure to explain what you are doing and what you are seeing.

This topic contains 218 replies, has 59 voices.

Last updated by Andrey 4 years, 3 months ago.

Assigned support staff: Andrey.

Author Posts
August 28, 2015 at 11:51 am #692188

dylanM

Hi,

I need to downgrade as well since all my transtations are now missing as is the WPML option in the menu plus I receive the ICanLocalize message.

Please PM me with next steps.

Regards,

Dylan

August 28, 2015 at 1:03 pm #692262

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello @dylanm, I am activating the private reply where you can share the credentials for your site that will allow me to make the downgrade.

August 28, 2015 at 1:51 pm #692319

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Dear dylanM,
I completed the process for your site.

September 1, 2015 at 7:50 pm #695089

Nicolas

I need assistance to downgrade to the latest stable release. I have WordPress 4.3 and I have backed up the database.

I got the message
"Your website is configured to connect to ICanLocalize.
This version of WPML cannot be used in this case and it will be not functional until you downgrade or update, once available, to a version which is compatible."

Thanks,
-Nicolas

September 2, 2015 at 6:19 am #695282

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello Nicolas,
In order for us to make the downgrade process, we need that you provide temporary access to your site.
I am enabling the private form where you can share the access details securely, in your next reply.

September 2, 2015 at 2:10 pm #695867

Douglas

After a week of seeing RED highlighted Must Update list of plugins...we did. Needless to say it completed screwed up the websites...since we're translating with ICanLocalize - of course it DIDN'T state on the wordpress alert that it was NOT compatible.

We finally deleted all the plugins and after a painful search found an older version of WPML Multilingual CMS Version 3.1.9.7 that seems to at least get the site back to normal - now we need the other plugins that are compatible with this version -- would you be so kind as to direct me to the area to download the older version of the plugins.

Lesson - don't delete the older version of the plugins.

September 2, 2015 at 2:33 pm #695904

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello Douglas, I am terribly sorry about your experience with the upgrade.
The compatibility with ICanLocalize is the reason why this update was released as a manual update and it is mentioned here in the post that accompanied the release of WPML 3.2: https://wpml.org/2015/06/wpml-3-2-released/

Please find here the links to the changelog page and find the appropriate version that should work:
WPML Multilingual CMS 3.1.9.7: https://wpml.org/download/wpml-multilingual-cms/?section=changelog
WPML String Translation 2.1.4: https://wpml.org/download/wpml-string-translation/?section=changelog
WPML Translation Management 1.9.11: https://wpml.org/download/wpml-translation-management/?section=changelog
WPML Media 2.1.9: https://wpml.org/download/wpml-media/?section=changelog

I am sorry that I cannot provide you with a direct link, but this is based on your account and it is different every time.

Please also note that you will need further assistance, because of the changes in the database introduced since the update.
If you provide me with temporary credentials, I could revert the versions to the working ones and also make the appropriate changes in the database. However please remember to make complete website and database backup before that.

If you would like me to do the process for you, you can complete the following form in your next reply where you can provide the needed credentials securely.

September 2, 2015 at 3:06 pm #695961

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

@douglas,
All links should be available when you go to Account > Downloads and select the changelog link for the appropriate plugin.
The other compatible with the previous release plugins are:
WPML Sticky Links 1.3.9: https://wpml.org/download/wpml-sticky-links/?section=changelog
WPML CMS Nav 1.4.7: https://wpml.org/download/wpml-cms-nav/?section=changelog
Gravity Forms Multilingual 1.2.2: https://wpml.org/download/gravityforms-multilingual/?section=changelog

September 2, 2015 at 3:08 pm #695964

Douglas

Thanks George.

September 3, 2015 at 9:40 am #696641

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

@nicolas the process for downgrading is complete for your site.
However I see a lot of issues that this site is having that are not related to WPML.
I would suggest you to check the errors reported in the backend and try to run for testing purposes in a minimal setup.

September 3, 2015 at 7:18 pm #697271

Kristin

I can successfully install the core WPML plugin, but it alerts me that I need to downgrade to a version that is compatible with Icanlocalize for any of it to work. If I could get the latest compatible version of WPML it would be most appreciated.

September 3, 2015 at 9:25 pm #697340

Kristin

Any idea if/when there will be an update to Icanlocalize so that we can use the newest version of WPML?

September 4, 2015 at 6:34 am #697465

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello Kristin,
In order for me to make the downgrade procedure, I would need a temporary access to your site.
I am enabling the private reply where you can share this data if you are willing.

For your other question - our developers are working now on a way to migrate the ICanLocalize enabled sites, and the solution should be available relatively soon.

September 5, 2015 at 12:48 am #698271

Nicolas

Dear George,
Thanks, I saw that you downgraded my WPML. I deactivated all plugins and fixed and error introduced by BPS, then I ran the web site with no errors, however when I activate WPML Multilingual CMS, I see the following error in the apache error_log. After that, the site seems to work, but I can't edit the posts nor can I request translations, etc. I am running PHP Version 5.4.44.

Apache error_log:
[Fri Sep 04 20:27:29 2015] [error] [client xxx.xxx.xxx.xxx] PHP Fatal error: Call to undefined function mb_strtolower() in .../wp-content/plugins/sitepress-multilingual-cms/menu/post-menu.php on line 78, referer: hidden link

Also, I see the following notification in WordPress:
WPML can't run normally. There is an installation or server configuration problem. Show details
AJAX Error: Internal Server Error [500]
URL:hidden link

September 5, 2015 at 1:19 am #698276

Nicolas

Dear George,
I replaced the offending mb_strtolower for strtolower calls (there are several) and things seem to be working now. However, modifying WPML code is not y first choice.

I also see the following warning a lot:

[05-Sep-2015 01:06:01 UTC] PHP Warning: filter_input(): charset `ANSI_X3.4-1968' not supported, assuming utf-8 in .../wp-content/plugins/sitepress-multilingual-cms/inc/comments-translation/functions.php on line 559

Thanks,
-Nicolas