This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Finally, after very long (and complex) development, ICanLocalize clients can upgrade WPML to its current version and continue to enjoy a streamlined translation workflow.

Problem :

It wasn't possible to use ICanLocalize translation service with the WPML greater than 3.2, if you have done some translation through the service already.

Solution :

Read carefully this article : https://wpml.org/2015/09/migration-for-icanlocalize-clients-to-wpml-3-2-x/

Just to summarize about how to Update to the Current WPML Version :

1. Take a backup 2. Deactivate and remove an old version of WPML plugins 3. Download the newest ones from here : https://wpml.org/account/downloads/ 4. Install and activate the latest WPML plugins (WPML 3.2.7, WPML ST 2.2.6, WPML TM 2.0.5) 5. Download plugin "Migrate ICanLocalize Translation to WPML 3.2" : https://wpml.org/download/migrate-icanlocalize-translation-to-wpml-3-2/ 6. Install and activate it. 7. Go to the new menu that the plugin created for the migration process WPML->Migrate ICanLocalize Translation to WPML 3.2 8. You will see two buttons. First, click to migrate the account to WPML 3.2. This runs almost instantly. Then, click to migrate the jobs. 9. You no longer need the migration plugin. Go to Plugins and deactivate it.

If there are any problems in this migration process (there should not be), the migration plugin will report them on the screen. Create a new ticket in WPML technical support forum, copy what you see and paste in the forum thread. Be sure to explain what you are doing and what you are seeing.

This topic contains 218 replies, has 59 voices.

Last updated by Andrey 4 years ago.

Assigned support staff: Andrey.

Author Posts
April 20, 2015 at 8:20 am #602253

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@emmanuel, I have made the downgrade. The other extensions I had to deactivate, you also need to change them to the latest official versions (not use the beta versions).

April 20, 2015 at 11:51 am #602461

Elizabeth Koster

I am looking for WPML string translation plugin v2.0.3 as the latest version has problem with the Realty theme and the maker of the theme suggested to get an older version of the plugin.

Kind regards,

April 21, 2015 at 4:05 am #602891

Curtis

Hello,

I upgraded to 3.2 RC2 to see whether issues of disappearing media were fixed (another story), but they were not. When I tried to deactivate all the plugins, I eventually got: "Fatal error: Call to a member function get_backtrace() on a non-object in /home/kastler/www/wp/wp-content/plugins/sitepress-multilingual-cms/inc/query-filtering/wpml-query-filter.class.php on line 28".

I want to either downgrade, or just remove this version. I have not translated anything at this point, so nothing to lose.

Thank you

April 21, 2015 at 6:02 am #602925

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@elizabeth, I am strongly recommend do not use the outdated plugins the latest official version of String Translation is 2.1.3. The version you are asking, have been released 2 year ago, I am completely sure that it will not work fine with the current versions of WPML, WP.
The theme author gave you wrong suggestion, I believe he needs test his theme for compatibility. You can open a new ticket and describe your issue there, if it is compatibility, then our team will send request to the author asking him to make his theme compatible with WPML, but it depends on him.
You also can invite him join to our Go Global program :
https://wpml.org/documentation/theme-compatibility/go-global-program/

@curtis, if you have nothing to lose, try to deactivate all addons and then go WPML >> Support > Troubleshooting and click "Reset all language data and deactivate WPML". After, just install the latest official versions and configure WPML again.

April 28, 2015 at 11:12 am #607720

massimilianop-6

i incorrectly installed beta version
Now i replaced wrong files with corect
i already backed up database
What have i got to do to downgrade now?

April 29, 2015 at 11:37 am #608726

massimilianop-6

i incorrectly installed beta version
Now i replaced wrong files with corect
i already backed up database
What have i got to do to downgrade now?
please help me

April 29, 2015 at 9:18 pm #609221

massimilianop-6

i need help

May 4, 2015 at 1:25 pm #611296

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@massimilianop-6, please provide the access credentials in the private field.

May 6, 2015 at 10:42 am #613048

marioO-4

Hi, I've installed WPML 3.2 RC2 and I would to downgrade to 3.1.9.5.
Duplicator plugin doesn't work, but I've done backup of database with PhpMyAdmin and I downlaod my site.
Somebody can help me?

May 11, 2015 at 1:45 pm #616379

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

marioO-4, please provide the access credentials in the private field.

May 13, 2015 at 8:00 am #617703

paoloV-4

HI I'm in trouble with the istallation with WPML on a woocommerce site.
The wpml Italian support said me to downgrade it because of the problem can be the older version ,
How we can solve that problem? It seems like the e-commerce does'nt work.
this is the site hidden link

May 18, 2015 at 2:01 pm #620806

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@paolov-4, Do you want to make a downgrade ? I want to remind that here I can help you to make a downgrade, but not solve the problem that you have. If you have still the issue after the downgrade then you need back to your original reported ticket and continue with the support that is assisting you.

May 22, 2015 at 2:59 pm #624501

raulL-4

I'm getting the same issue that I can't use WPML 3.2 RC due to the icanlocaliaze configuration.

I'm not using Icanlocaliaze and I would like to disable it, as I need the new version due to one bugfix in it.

Could you guide me how to disable to functionality which does not allow me to use RC?

(We can handle manual database updates).

May 25, 2015 at 6:42 am #625128

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+03:00)

@raull-4, this ticket is for helping with downgrade the version. In order to ensure that your problem gets the attention it deserves, please open a new ticket detailing your issue.

June 1, 2015 at 9:16 am #629559

Naveen Panwar

I am getting this error.

Call to undefined function wc_get_product() in /home/natuzrll/public_html/wp-content/plugins/woocommerce-multilingual/inc/products.class.php on line 1368

And Because I did some mistake in the start with woocommerce i can't even upgrade it.
So please help me downgrade my wmpl plugins and help me remove this error.

This error comes in COD(Cash on delivery) only works fine with paypal.