If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by alexanderA 1 year, 4 months ago.

Assigned support staff: Bobby.

Author Posts
July 6, 2018 at 5:36 pm #2471579

alexanderA

Hello. I am trying to duplicate my page into another language. But the option to duplicate is not in the usual place on the page (see attached screenshot). How can I resolve this?

When I created this ticket, I tried to select 'Something is not doing what I expect it to,' but it wouldn't let me submit the ticket without uploading a Duplicator file, which seems fairly unnecessary. I think that requirement needs to be relaxed.

July 6, 2018 at 10:13 pm #2471923

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

This is most likely happening due to your WPML Settings.

Please go to WPML->Settings->Post Types Translation and select "Translatable - only show translated items" for "Pages".

this will show the duplicate option again.

you are not seeing this now because the option "Translatable - use translation if available or fallback to default language" is selected , which shows the content of your default page in the secondary language without needing to "duplicate"

July 7, 2018 at 6:10 am #2472078

alexanderA

>> Please go to WPML->Settings->Post Types Translation and select "Translatable - only show translated items" for "Pages".

OK I Understand that. But I in-fact want to ensure the option "Translatable - use translation if available or fallback to default language" is selected. If a page does not have a Chinese translation or duplicate, I want the default language to be displayed. So I want to keep "Translatable - use translation if available or fallback to default language" selected.

My ultimate goal is this. I want to create a Chinese version of my English page. But I don't want to start with zero content--I want to start with the English content, then slightly modify that. This is why I wanted to first 'duplicate' the EN page into CN.

What if I did this. What if I kept my WPML settings as-is, and open the English page for editing, click the + under 'Translate' (see attached screenshot hh-cn-back-1), then on the new page, click 'Copy content from English' or 'Overwrite with English content' (see attached screenshot hh-cn-back-2)? Would either of those do what I want? It sounds like it, but I just want to be sure.

Thanks.

July 7, 2018 at 6:04 pm #2472848

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

correct, these options would do what you want to achieve.

please let me know if that does not work as expected.

July 8, 2018 at 12:40 pm #2473682

alexanderA

OK that worked, thanks. We can consider this resolved.

July 8, 2018 at 12:56 pm #2473697

alexanderA

Actually sorry, that method does not make a complete duplicate of the page. It merely copies the text content. But there are still several custom fields on the page that I would like copied from the original (see attached screenshots). Other than manually re-adding the values of these custom fields, what would be the best way to do this? Can I duplicate this page via WPML-->Translation Management? Or can I temporarily set WPML->Settings->Post Types Translation to "Translatable - only show translated items" for "Pages," duplicate the page, then reset it back to "Translatable - use translation if available or fallback to default language?"

I'm not sure why page duplication is disabled if "Translatable - use translation if available or fallback to default language" is enabled.

Thanks.

July 9, 2018 at 4:20 pm #2477170

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

as a test what are your results if you do the duplication from within the Translation Management dashboard ?

if that does not work then please try the following and let me know your results

"duplicate this page via WPML-->Translation Management? Or can I temporarily set WPML->Settings->Post Types Translation to "Translatable - only show translated items" for "Pages," duplicate the page, then reset it back to "Translatable - use translation if available or fallback to default language?""

July 10, 2018 at 3:18 pm #2482559

alexanderA

OK, duplicating via Translation Management seemed to work. That is a suitable workaround for now. Let's consider this resolved, thanks.