This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am unable to download the XLIFF files for translation

Solution: The plugin Woocommerce Customer Manager was causing a conflict.

0% of people find this useful.

This topic contains 23 replies, has 2 voices.

Last updated by Lauren 1 year, 5 months ago.

Assigned support staff: Lauren.

Author Posts
May 1, 2018 at 6:45 pm #1916590

mikeE-8

Tell us what you are trying to do?

We have an external translator that says they need files in XML format. I searched WPML, but could only find some forum posts on XLIFF, but no clear instructions, or step-by-step procedure for exporting XLIFF. For example, do we create the translated pages without any data first? Or do we mark settings to copy over the English text, and then export posts in XML or XLIFF? How/where do we do this?

Is there any documentation that you are following? None that I could find.

Is there a similar example that we can see? N/A

What is the link to your site? Will send privately.

May 2, 2018 at 8:47 pm #1943375

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

You do not need to create the translated pages first. You can go to WPML -> Translation management and select the pages that you want translated. Then, go to the WPML -> Translation Management -> Translation Basket and send the translations to the translator. The translator will then be able to access the pages when he logs in under WPML -> Translations and there is an option to download the XLIFF files. Please see https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/ for further information, and let me know if you need further assistance.

May 2, 2018 at 9:23 pm #1943660

mikeE-8

Hi Lauren,

I tested this by sending the a translation to myself to download.

When I get to the Translations page, I select XLIFF 1.2, check the box next to the page to download and click "apply". A white screen loads and nothing else. No download starts.

Can you advise?

May 3, 2018 at 12:29 pm #1957027

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

Also, when you click apply, are you seeing any errors in your browser console? Here is some information about how to view your browser console: hidden link

May 3, 2018 at 8:02 pm #1965878

mikeE-8

Hi Lauren,

I don't see any errors in the console.

The following was output to an error log. I don't know what would be deemed sensitive, so I updated some URLs to include "0000". If you could mark this as private I would appreciate it. I think it's meant to be read backwards?

#6 /www/0000_563/publi" while reading response header from upstream, client: 97.86.240.144, server: staging-0000.kinsta.com, request: "GET /wp-admin/admin.php?page=wpml-translation-management/menu/translations-queue.php&wpml_xliff_action=download&xliff_export_data=eyJhY3Rpb24iOiIxMiIsImRvYWN0aW9uIjoiQXBwbHkiLCJqb2IiOnsiMzIiOiIxIn0sImFjdGlvbjIiOiIxMiJ9&nonce=1abb14b77e&xliff_version=12 HTTP/1.0", upstream: "<em><u>hidden link</u></em>:", host: "staging-0000.kinsta.com", referrer: "<em><u>hidden link</u></em>"

#5 /www/0000_563/public/wp-settings.php(450): do_action('init')

#4 /www/0000_563/public/wp-includes/plugin.php(453): WP_Hook->do_action(Array)

#3 /www/0000_563/public/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)

#2 /www/0000_563/public/wp-includes/class-wp-hook.php(286): WPML_TM_Xliff_Frontend->init('')

#1 /www/0000_563/public/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-xliff-frontend.php(111): WPML_TM_Xliff_Frontend->stream_xliff_archive(Object(wpml_zip))

#0 /www/0000_563/public/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-xliff-frontend.php(278): wpml_zip->sendZip('0000...')

Stack trace:

in /www/0000_563/public/wp-content/plugins/wpml-translation-management/inc/wpml_zip.php:481
2018/05/03 19:54:34 [error] 2563#2563: *3214 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Exception: Unable to send file '0000-translation-job-32.zip'. Output buffer contains the following text (typically warnings or errors):
May 3, 2018 at 10:01 pm #1966662

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please attach the full error message. I have marked the next reply as private.

May 4, 2018 at 12:13 pm #1974771

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the full error message. Please see this similar ticket, and try renaming the theme functions.php and/or wp-config.php. Then create a new one and paste the content of the old file inside the new one using a text editor. https://wpml.org/forums/topic/xliff-export-fails-unable-to-send-file/

Please let me know if this resolves the issue for you.

May 4, 2018 at 7:51 pm #1981418

mikeE-8

Hi Lauren,

Unfortunately that did not resolve the issue. The functions.php file contents were copied- I don't understand how creating a copy makes the file contents different?

May 4, 2018 at 7:53 pm #1981419

mikeE-8

I deleted the functions.php file completely, and that didn't resolve the issue either.

May 4, 2018 at 8:24 pm #1981777

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You need to copy and paste the content into a text editor. Then, copy and paste from the text editor. Also test the wp-config.php file. Using the text editor will strip any formatting that could be causing the error.

May 4, 2018 at 8:39 pm #1981955

mikeE-8

Hi Lauren,

I tried the instructions for functions.php and wp-config.php, but that didn't fix the issue.

I tried deleting the functions.php and that didn't fix the issue.

I tried the default 2017 theme and that didn't fix the issue.

May 4, 2018 at 10:40 pm #1984398

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

May 7, 2018 at 1:05 pm #2012459

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I was able to login, but I don't think my permissions are set correctly. I am not able to get to the WordPress Dashboard, just the /my-account/ page. Please allow me administrative permissions so that I can further troubleshoot. Thanks!

May 7, 2018 at 1:21 pm #2012685

mikeE-8

Sorry about that, the account has been updated.

May 7, 2018 at 8:41 pm #2020650

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for updating. I see that this is a staging site. Would it be possible for you to deactivate all non WPML plugins and and switch back to default theme Twenty Seventeen? Then, delete the existing translation job that you were trying to download. Go back to Translation Management and send the page back to the translation basket, and then try to download the XLIFF file. Now are you able to download it? If not, are you still seeing the same error in your debug log?

If you are still getting the error, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!