Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Konrad Karpieszuk 5 years, 1 month ago.

Assigned support staff: Konrad Karpieszuk.

Author Posts
September 16, 2016 at 7:54 am #1082879

Verein

I am trying to:
I have made my site first in ENGLISH and want to have this language the first appearing on the site and german as the second language. But as I installed WPML it shows all on the inverse: when I put "translate" the already existing english content is recognized as german and not as english and the translation which will be in german is shown as english. (Do you get me :->)
How can I change this so that the site remains with ENGLISH as first language and has GERMAN as second language to choose and to translate into now.
My Admin language is German and I want to remain it that way.
Can you help me?

URL of (my) website where problem appears:

I expected to see:
open site: my english content: the language flag: english
to choose the other language: german

Instead, I got: the contrary: I could (but do not want to) build up the site with german as first language and then take the english as the translation . can you help me please?

Steps to duplicate the issue:

September 16, 2016 at 11:42 am #1083399

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

Hello, I am Konrad and I will help you with this, but:

> Do you get me :->

actually I don't 🙂 But I think if you will give me wp-admin access and I will see what you see, then I will understand your description better.

I am marking your next reply as private so only I will see your password

September 19, 2016 at 6:15 am #1086703

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

Hello

Ok, now I understand.

To make English language first:

This language switcher always as first displays current language. Your default language is German, so when user visits your MAIN site, he sees German.

To change default language: go to WPML > Languages and in top part click "Change default language" and there select English.

If this will change your wp-admin language to English and you want to stay with German: go to Users > My profile and from list of languages select preffered language.

---------

The second thing, which you presented at screenshot: that when you edit post you see only German on the list of language which you can choose. ( https://wpml.org/wp-content/uploads/2016/09/1083662-Bildschirmfoto_2016_09_16_um_15.48.54.png )

As you can see just under this list, this post has English translation and this is why you cannot switch it. First you need to delete English translation or change English post language to something else.

But when you will try to do this, you will see that you have the same problem: En post has German translation so from a list you can choose only English.

To overcome this I suggest to add another temporary language, for example French.
- change English pots temporary to French
- then you will be able to change German post language to English
- then change French post to be German
- remove French language completely from your site

I hope I helped 🙂

September 19, 2016 at 8:10 am #1086823

Verein

Dear Konrad,

RESOLVED
simply fantastic: thank you so much! This was the perfect and clear answer and I could resolve the problem.
I have changed the pages and the posts in german and english and will go for the translations now.

PORTFOLIO CANNOT BE TRANSLATED
When I wanted to add the german in "portfolio" pages I saw that I cannot make a translation with WPML there: see screenshot. Do you have a solution for this? In the worsest case I can eventually add new portfolio items in german as a translation and assign them to the german content. (if you need, my login data are still the same)

LANGUAGE SWITCHER ON HEADER
Another issue (I can of course open a new ticket if necessary) I want to resolve is that if possible I would prefer to have the language switcher in one line with EN | DE - see screenshot. I already use some code to put it where it is now, perhaps you have some code (or idea) to help me with that?

Anyway, great answer and help!
Thank you so much!
Best, Maria

Bildschirmfoto 2016-09-19 um 10.06.03.png
Bildschirmfoto 2016-09-19 um 09.58.56.png
September 19, 2016 at 8:21 am #1086868

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

Hello

I am happy that I helped 🙂

For two other issues is the best to open new tickets, but maybe my quick answers would help you. If help, I am happy again. If not, please create new ticket (and mention that you have tried my proposed solutions so we will not offer you the same again).

Portfolio: please go to WPML > Translation Management > Multilingual Content Setup and in section "Custom posts" find your Portfolio and mark it as translatable (you need to have WPML Translation Managament plugin active, but if you don't have and don't want to activate it, you will find the same in WPML > Multilingual Settings)

Custom menu: looks like you will have to encode it yourself because WPML does not provide such kind of menu. But this will be quite easy if you are PHP/CSS friendly. Here is documentation: https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

I hope you will not have to open tickets for that and this is satisfying answer 🙂

September 23, 2016 at 8:15 am #1096368

Verein

Dear Konrad,

sorry for my late reply. Again your help was fantastic. The portfolio problem was resolved with your instructions within a second. It took me longer for the language switcher which I am still on it. So I will open a new ticket for this as you advised me. Thank you so much for your help!
All the best!

September 23, 2016 at 8:17 am #1096372

Konrad Karpieszuk
Supporter

Languages: English (English )

Timezone: Europe/Rome (GMT+02:00)

I am always happy when I hear that I've helped 🙂 Thank you for a kind words!