This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 4 voices.

Last updated by Michele 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 12, 2019 at 9:11 pm #3602003

ninaS-6

Tell us what you are trying to do?
My site is French, but I speak only English. I can't seem to get the settings correct so that my plugins in the admin remain in English.

For example, UpdraftPlus gives me French reports. How do I ensure that the admin is English for all my plugins?

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

April 13, 2019 at 9:44 am #3604139

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

- Does this happen when the Dashboard language is set to English by using the top bar language selector?

- Can you please try disabling the "Set admin language as editing language" option from Users -> Your Profile?

- Check also if there is some aggressive server caching method enabled.

Thank you

April 16, 2019 at 3:07 pm #3623293

ninaS-6

Hi. what I sent last time was when the dashboard language was set to English via the top bar. I followed your instruction re: disabling the "Set admin language as editing language" option from Users -> Your Profile- and it is still French.

I am not sure if there is aggressive server caching - but if there is I suspect I have no control over that. I have asked, and am waiting on a response.

April 16, 2019 at 4:34 pm #3624057

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Thank you,

I will wait for updates about the server cache.

In the meantime, can you please verify if the same issue happens using a different browser.

Is the same issue happening for other plugins?

Thank you

April 16, 2019 at 7:47 pm #3625205

ninaS-6

I have been told that aggressive server caching is not enabled.
The same issue happens in other browsers.
I do not have the same issue with other plugins at the moment, but the other day I thought I did.
Is this set up properly? (see image)

April 18, 2019 at 4:22 pm #3640761

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I tried to reproduce the issue on a fresh WordPress install, but I was not able.

Here: hidden link

You can compare the settings between your site and the Sandbox.

Can you please verify if the Original language of the strings shown in the first screenshot or of the entire text domain for Updraft, has been incorrectly set to French?

Thank you

Related documentation:
https://wpml.org/documentation/getting-started-guide/string-translation/#original-language-of-strings

April 25, 2019 at 5:30 pm #3684741

ninaS-6

Hi,
I compared settings, and even if I have mine matched to yours, the UpdraftPlus plugin is French. So this could be because I have the Premium version?

Updraft support told me to set the site to English, and said “UpdraftPlus will switch whatever language is used on the site.” This is odd to me because you somehow got it to work.

So for me, the only way to make Updraft English is to set the site to English.

Another difference is that I have a multisite install. Even if I have only ONE site set to French in the multisite Network, the Updraft becomes French. But the issue also occurs on my single site install, so it seems related to the UpdraftPlus Premium version - or some setting that I cannot find.
I changed the Theme to 2019 - still French.

I uninstalled WPML and UpdraftPlus. Then re-installed UpdraftPlus (premium). It was English.
As soon as I installed WPML - it became French again. Are there some WPML settings that did not get deleted in the reinstall? - How can I flush them out?

April 26, 2019 at 5:37 pm #3692653

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
My name is Carlos and I will be taking this ticket because our colleague Vincenzo is on vacations today.

I suspect that it could be a few causes for this issue:
1.- A misconfiguration in the WPML plugin.
2.- For some reason WPML scanned the Updraft plugin and assigned the string to the wrong language.
3.- The multisite somehow is affecting the backend of Updraft.
4.- There is a conflict between WPML and a third party plugin.

For this reason I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

April 29, 2019 at 6:20 pm #3705995

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I applied several tests but I can't find the cause of the issue. I created a test site with a fresh new WordPress install and WPML installed and activated.

I kindly ask you to try to reproduce the issue in this test site and let me know the results. You can access the backend of the site directly from this link: hidden link

Looking forward to your message.
Best regards,
Carlos

May 1, 2019 at 8:12 pm #3719769

ninaS-6

Hi - I did not test on your sandbox, but I do have another test site. As soon as I activated the premium version of Updraft, the plugin changes to French (or whatever is set as the site language).

Is there a way in WPML that I can assign a language to that plugin? Then I can try to assign it to English CAN.

I have tried dumping the French .po .mo files in the wp-content>languages>plugins directory, but they keep coming back.

May 2, 2019 at 5:15 pm #3727557

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Does this test site is a fresh new WordPress installation? Or is it a copy of the live site?

Regards,
Carlos

May 2, 2019 at 6:31 pm #3728299

ninaS-6

Hi Carlos - it was a fresh install, with the theme demo (Newspaper), and very few plugins. It is not a new install, but one that was installed a while ago. When I get a chance I can install the Updraft Premium on your demo - I'm feeling like that is the issue: Premium vs free.

Since I need to have the premium version, I thought it would be better to try another direction: trying to assign a language to the Updraft plugin through WPML.

May 2, 2019 at 6:44 pm #3728353

ninaS-6

Hi again Carlos.
I added the Updraft Premium plugin to the demo site you provided.
I changed the default language of the site to French.
I changed the user profile preference language to English.

Updraft is in French. I need it to be English.

Thanks!

May 2, 2019 at 7:52 pm #3728953

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your messages.

I will take a deeper look at this issue and I will get back to you as soon as I have an answer.

Thank you very much for your patience.
Regards,
Carlos

May 3, 2019 at 2:56 pm #3735817

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your patience.

I have escalated this ticket to our compatibility team. Our compatibility specialists will take a deeper look at this issue and will try to find a solution.

I will keep you updated on the evolution of this ticket.
Regards,
Carlos