This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

How can I make all images from the media library available in all languages (without having to update them again)?

Solution:

In order to translate existing media and make it available for all languages:

1. Go to WPML > Settings > Media Translation 2. Check the "Translate existing media in all languages" box 3. Click the blue "Start" button

You will see that there are many many settings in this section related to media so feel free to experiment as you see fit.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/media-translation/

This topic contains 2 replies, has 2 voices.

Last updated by antoinetP 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 1, 2018 at 4:16 pm #2778742

antoinetP

Hello
How can I make all images from the media library available in all languages (without having to update them again)?
We have a lot of images we already use in both FR and EN versions.
Thanks for your help

October 1, 2018 at 6:50 pm #2779196

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

In order to translate existing media and make it available for all languages:

1. Go to WPML > Settings > Media Translation
2. Check the "Translate existing media in all languages" box
3. Click the blue "Start" button

You will see that there are many many settings in this section related to media so feel free to experiment as you see fit.

Here is also some very useful documentation:
https://wpml.org/documentation/getting-started-guide/media-translation/

Let me know if this helped you accomplish what you needed or if you still need help.

October 5, 2018 at 7:29 am #2789718

antoinetP

My issue is resolved now. Thank you!