This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 27, 2019 at 3:05 pm #4101145

jackT

The site used to be in two languages, English (default) and Dutch. The site also has products (Woocommerce). Because we only want to keep English, can I remove WPML safely from the website? Or are there steps to take before doing this?

hidden link

June 27, 2019 at 3:09 pm #4101201

jackT

I'm also getting this error at the moment:
"WPML could not load configuration files, which your site needs."

See screenshots for the errors.

June 27, 2019 at 6:59 pm #4102363

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Hope you have created all the posts, pages and taxonomies in the default language(English) and translated it to Dutch. If so, you can clear all the translation by resetting WPML. It will reset WPML settings and clear all the translation data. Please try the following steps after a full site backup and make sure you are getting the expected result or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page scroll down to *Reset* section(on the bottom of the page)
4) Choose *I am about to reset all translation and language data.* checkbox
5) Click on *Reset and deactivate WPML* button

You may be getting the following warnings because of the older version of WPML. The latest version is 4.2.7.1.

WPML could not load configuration files, which your site needs

--
Thanks!

Bigul

July 7, 2019 at 8:32 am #4157403

jackT

Please keep this ticket open a little while longer. I have not been able to test it yet because of other work.

July 8, 2019 at 6:50 am #4159365

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Take your time. We will wait for your feedback.

--
Thanks!

Bigul