This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.03 hours from now. Thank you for your understanding.

This topic contains 10 replies, has 2 voices.

Last updated by eminiA 5 years, 8 months ago.

Assigned support staff: George Botsev.

Author Posts
October 27, 2014 at 10:00 pm #500476

eminiA

Hello, I recently got support from your team with the problems I had to translate string to Albanian language. But I marked it as solved before I got the last questions answer. Can you tell me please how did you add this:

Select strings within context: plugin_woocommerce
At the string translation menu the plugin_woocommerce wasn't listed on the dropdown menu.. How can I add this ? DO I need to scan for this string from somewhere ?

Second questions is where are saved these strings which I am translating from String translation menu or if they aren't how can I save them?

October 28, 2014 at 12:21 pm #500908

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello.
Please review the post here https://wpml.org/forums/topic/i-need-to-translate-store-pages-cartcheckoutshopaccount-to-three-languages/
I have added description of the solution there.

October 28, 2014 at 2:11 pm #501031

eminiA

Ok now I have another problem with the products if you can help me please. I translated the woocommerce strings the ones I needed to translate. Now I wanted to start with creating Product Categories and Add the products in Albanian language first as default language then to translate them in other languages.

This is what I have done:
I created product Categories in Albanian, after that I add new categories as translation of original ones (Albanian lang.) --> screenshot-1 below.

After that I started to create products in Albanian and I planned after that to translate them one by one in other languages, but after I publish it when I press View product I get: 404 Error Page not found.
-->screenshot-2

Can you tell me what I'm doing wrong or what I need to do. I don't want to have English language added these three languages are enough. And I want albanian to be default language.

October 28, 2014 at 2:17 pm #501049

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I think that you have to create the product with the default language first in order for this to work.

October 28, 2014 at 3:54 pm #501182

eminiA

I am creating the product first in Albanian which is set as defaut language , or you mean in English ?

October 28, 2014 at 3:56 pm #501190

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

You could try to translate this via WPML >> WooCommerce Multilingual >> Products

I hope this helps you.

October 30, 2014 at 7:43 pm #503115

eminiA

I need a little more help for the dropdown language switcher,while working on the site suddenly I saw that the little nav-arrow icon from the dropdown menu was gone and in that place showed something laike in the image below.

The url is here: hidden link

October 31, 2014 at 7:57 am #503278

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I have visited your site and I cannot see the problem shown on your screenshot.
Perhaps you have fixed this?

October 31, 2014 at 12:27 pm #503488

eminiA

I founded where the issue was. The icon was from theme style.css it had a ::after class for the icon using Font Awesome as font-family but there was incorrect format of the content it is typed content: "f107";
in the place of content: "\f107"; But i don't know why I edited the style.css saved it but it again shows as "f107" for that I replaced the name of the class for ::after pseudo class.

October 31, 2014 at 12:34 pm #503495

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Yes, this looks like font awesome problem, but I have tested your site on Chrome, Firefox and Internet Explorer and I cannot see this problem showing up.
Please clear your browser cache and check again.
I am not sure why you cannot see the flag infront and why this is displaying in the back.

October 31, 2014 at 3:11 pm #503654

eminiA

No the flag is showing and that f107 is removed but I don;t know why the theme style.css removes the \ character in the content variable. Anyway now is good thanks for the support