This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Andreas W. 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 7, 2019 at 4:33 pm #3760531

anh-thiN

Tell us what you are trying to do ?

How to set the default language of admin to the edit language on administrator ?

My language is vietnamese, and then add to the language for english. My edit translate to english. You can see below image.

May 7, 2019 at 4:42 pm #3760637

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message and the screenshots.

If you go to your WordPRerss Profile you will see an option beneath the site language selection that say: "Set admin language as editing language."
Make sure to enable this option and the site default language should be the same admin language, means if you switch the language in the top admin bar the WordPress Back End will be changed accordingly.

In case there are still strings that are not translated, this must be because there are not anz persian translations available yet. You can translate those string with our String Translation module.
https://wpml.org/documentation/getting-started-guide/string-translation/

I hope this answered your questions. Let me know if you need further assistance.

Kind regards
Andreas

May 8, 2019 at 2:18 am #3763037

anh-thiN

Dear Andreas W. !

when i set admin language as editing language, and The Language site set to "Site Default".

I need vietnamese, but my site to english ?

May 8, 2019 at 7:45 pm #3770585

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

You will need to change the language option inside of your WordPress Profile to Vietnamese in order to show the backend in this language. While the default language for WPML will stay on English make sure to unmark the field "Set admin language as editing language."

See screenshot attached.

Kind regards
Andreas

May 9, 2019 at 1:46 am #3771811

anh-thiN

Dear Andreas W. !

i used the vietnamese for admin, when i change the language. The the sub categories changed,too.

May 9, 2019 at 5:32 pm #3778427

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry for not beeing able to follow you.

On your screenshot you are on a Chinese post and the categories are displayed in the respective language. This is default behavior of WPML.

Could you please clarify you request a little further?

Also, as you changed now the site language Vietnamese, you might find some strings on the backend that are not appearing translated, when it comes to theme or plugin otpions. Those strings should be able to locate and translate with our String Translation add-on.
https://wpml.org/documentation/getting-started-guide/string-translation/

Let me know if this answered your question.

Kind regards
Andreas

The topic ‘[Closed] How to set the default language of admin to the edit language on administrator’ is closed to new replies.