This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Noman 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
September 3, 2019 at 3:52 pm #4506009

magnusJ-3

Tell us what you are trying to do?
Translate the Elementor theme builder header (and footer) parts with the design from this hidden link to this: hidden link
Is there any documentation that you are following?
Have googled but have not found any good ones.
Is there a similar example that we can see?
No
What is the link to your site?
See above

September 3, 2019 at 4:58 pm #4506493

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- Please follow our step by step documentation here to translate Elementor header template:
https://wpml.org/documentation/plugins-compatibility/elementor/#translating-header-templates

And let me know how it goes?

Thank you

September 5, 2019 at 4:34 pm #4520749
magnusJ-3

Thanks so much, i think I got it to work the right way now.

One more question:
My demosite is hidden link but I will use the duplicator plugin to move this demosite to the "real" .com adress for the english version. And I want the Swedish version of that site to be .com/se

Because of that I have tried to change my Swedish version on the site to /se (not /sv which is preset for Swedish in WPML). Did I do this right? Or will google or someone else think something is wrong? Please see my attached image.

Also, I get this message: You need to configure at least one more language in order to access "Theme and plugins localization" and "Media translation".

Have I done something wrong when I get this message?

All the best,

Magnus

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/one-more-question/

September 8, 2019 at 8:33 am #4530805

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have created a new ticket to handle it separately. Here is the link to the new ticket: https://wpml.org/forums/topic/one-more-question/

Thank you for your cooperation and patience.