This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by frankW-15 2 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 5, 2019 at 6:10 am

frankW-15

I am trying to: Set "Display Language in" to German and saving does not work.

In General: how ist the workflow for translate widgets in wpml?

The client just try to translate the widgets and recieved this Error-Message:

Fatal error: Uncaught ArgumentCountError: Too few arguments to function SitePress::terms_clauses(), 1 passed in /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-includes/class-wp-hook.php on line 288 and exactly 3 expected in /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:2525 Stack trace: #0 /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-includes/class-wp-hook.php(288): SitePress->terms_clauses(Array) #1 /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-includes/plugin.php(208): WP_Hook->apply_filters(Array, Array) #2 /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-includes/class-wp-term-query.php(654): apply_filters('terms_clauses', Array, Array, Array) #3 /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-includes/class-wp-term-query.php(288): WP_Term_Query->get_terms() #4 /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-inc in /homepages/12/d663532946/htdocs/clickandbuilds/ChemSynergy382626/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2525

There is also some problems with permalinks in the menu navigation links:

If you click on "Company", the client has change the permalink to:
"hidden link"
but it supposed to be hidden link

Did you need an temporary access to the page?

Link to a page where the issue can be seen: hidden link

So would be great if you can help us.

Best regards
Jörg Fiedler (Webdesigner for this page)
info@jfmediendesign.de

August 5, 2019 at 1:20 pm #4340825

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

This seems like any of your plugins might be conflicting with WPML. I would request you to do some basic troubleshooting.

- Backup your site and database
- Disable all non-WPML plugin, Check if the widgets can be saved
- If the problem disappears, Try enabling the plugin one to be one to single out the conflicting plugin.

Let me know the results.

Kind regards
Raja

August 5, 2019 at 4:28 pm #4342017

frankW-15

Hello Raja,
thanks for your Support-Message. We disabled all non WPML Plugins and now widgets could be saved in german or englisch. Could be Jetpack, but not for sure.

But we need your assistance regarding to the permalink structur of 2 pages:
Company = (Permalink now is set to: hidden link)
Contact = (Permalink now is set to: hidden link)
Normaly the Permlinks should be after /en/company and /en/contact.
But this did not work - always the german version was shown.

Could please login with the credentials an check these 2 Sites and Permalinks?

Thanks an best regards
Jörg Fiedler

August 6, 2019 at 5:39 am #4344277

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please goto WPML > Settings > Translated documents options,

Choose the option "Translate (where the slug is included in the translation and not automatically created from the title)
"
- Update the original content of Contact and Company pages, You don't need to do any changes.

- Edit the translation of the page, you should see the URL (slug) for translation for the pages in the Translation Editor, Complete the translation and update the page.

Check if the issue can be resolved. Let me know the results.

Kind regards
Raja

August 6, 2019 at 11:11 am #4346693

frankW-15

Hello Raja,
thank for help. For the sites "Firma/Company" it works.
The Contact Page did not work. As you can see in Screenshot in the english dashboard->pages, for the contact page is the small gears-icon visible.
But for the Contact Page in German is already a complete translation. If i click on the gears icon, WPML want the german translation.
I notice, that Yoast SEO Premium has some redirects for contact + kontakt.

So could you have a look once again, please?
We don`t know whats going wrong.

Best regards
Jörg Fiedler

August 6, 2019 at 12:05 pm #4347107

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have restored the german kontact page from trash (I am not sure why it is in the trash), Please complete the translation of the page this would fix your issue.

I am now able to access the English contact page without any issues hidden link

Let me know if you need further assistance.

Kind regards
Raja

August 6, 2019 at 12:58 pm #4347645

frankW-15

Hello Raja,

the site what you restored is a wrong kontakt page with content in english.
Now we have in german 2 kontakt pages - the one you restored has a permalink and slug kontakt-2.
If you been on the german "kontakt" page and click on the english flag icon, it redirects to the english startpage. Thats also wrong.

So could you please correct the side that there is a german "kontakt" page, and an english "contact" page with correct links for the flag-navigation icons. And check vise versa please.

Mr. Wieczorek is now very annoyed that WPML does not deliver the links of the individual language pages correctly.

Best regards
Jörg Fiedler

August 7, 2019 at 6:01 am #4352193

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I will try to explain the issue here,

The reason the English contact is redirected is to the home page is
- There are two versions of the English contact page.
* One created with English as default language hidden link

* Another one is created as a translation of the german page which is now redirecting to home page since there is already a page with contact as slug and Translation management is unable to create the page for the translation.

- I checked this page hidden link and opened the german translation which is already trashed I restored it from trash to make the connection. However, it seems like the page needs to connect to the existing german page instead of creating a translation of it.

- I have undone the connection now, I would request you to kindly follow the below steps.
- Secure a backup of your site and database

- Open the link hidden link , Move this page to trash

- Open hidden link in edit screen click update and open the English translation in the translation editor

- Complete the transaltion and save again

- Goto Settings > Permalinks Resave the settings

- Goto WPML > Support > Troubleshooting (check screenshot )

- On the troubleshooting page click on the following
[x] Clear cache with WPML
[x] Recreate ST Db table cache

Once the process is complete, Clear the site cache, check if the issue is resolved.

Let me know the results.

Kind regards
Raja

August 7, 2019 at 8:55 am #4352963

frankW-15

Hello Raja,

thanks for your help. I did all steps as you mention above.
Now the english page "contact" is missing, also in the english menu.
Thought that the new translation from the german contact page to english, wpml generates automatic a new english contact page?

Whats going wrong and have a look at the page?

Best regards
Jörg Fiedler

August 7, 2019 at 4:30 pm #4356863

frankW-15

Hello Raja,

think i resolved the problem, due to finaly remove the "contact" page from trash (not only move to trash)
Then WPML generates a new english "Contact" Page from the German Site.

I adviced Mr. Wieczorek to Check the site by himself, if it is ok, i set this Support Ticket to resolved.

Best regards and thanks again
Jörg Fiedler

August 7, 2019 at 4:56 pm #4356951

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Glad you are able to resolve the issue. Thanks, for the update. I hope I was a bit of help to you. Feel free to contact us if you need further assistance.

Please mark the ticket as resolved.

Kind regards
Raja

August 13, 2019 at 10:37 am #4387093

frankW-15

My issue is resolved now. Thank you!