This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: We have our own page template for many different sites. Some of our text blocks are inside the html tags. Is it possible to translate them? I don't see any options to translate our text blocks inside your plugin.

Solution: An XML configuration (https://wpml.org/documentation/support/language-configuration-files/) needs to be created in order to "let WPML know" about custom content.

This topic contains 2 replies, has 2 voices.

Last updated by stefanO-19 1 month, 4 weeks ago.

Assigned support staff: Radu.

Author Posts
August 10, 2019 at 3:10 pm #4375757

stefanO-19

Tell us what you are trying to do?

We have our own page template for many different sites. Some of our text blocks are inside the html tags. Is it possible to translate them?
I dont see any options to translate our text blocks inside your plugin.
Furthermore I have the same issue on other sites (not seeing all text blocks to translate)
Right now your plugin does not translate even one page.
Google translate can access them but the translation is really bad.

August 12, 2019 at 5:33 am #4378455

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Stefano,

Thank you for reaching out the WPML support!

Is there any chance that you can share some more details about these text blocks inside the page templates, please? I just want to understand what are you using so I can see what can we do in order to translate it.

Usually, a XML configuration (https://wpml.org/documentation/support/language-configuration-files/) needs to be created in order to "let WPML know" about custom content, and maybe this is what will do the trick this time too. However, I want to first understand what you're using so I can point you to the right solution.

Thanks,
Radu

August 21, 2019 at 9:39 am #4429567

stefanO-19

My issue is resolved now. Thank you!