Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 years, 11 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
February 4, 2019 at 12:59 pm #3157559

martineG-3

Hello,
We're using the "Portfolio Filter Gallery Premium" by A WP Life.

With this plugin you can create galleries and you can place an ID-code in the page.
However, when I want to translate the page from dutch to English or French only the first image appears.
What is the best way to translate the images used in the plugin?

February 4, 2019 at 7:26 pm #3159248

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It all depends how the gallery is being setup in this plugin, at first place I would recommend you the following:

1 - Make sure the images are available in both languages, you can confirm it in your WordPress Dashboard > Media menu.

2 - In your WordPress Dashboard > WPML > Settings > Media Translation check the option to duplicate the existing media content for your secondary languages.

Please, let me know if it helps, have a nice day.

February 7, 2019 at 12:11 pm #3170028

martineG-3

Hello Marcos,
The problem is that the module doesn't show up at all in the translated pages.
You can see the issue on hidden link.

The dutch version shows galleries, but on the translated pages the galleries aren't visible.
If you want I can give you access to the backend?!
Thanks in advance
Tony

February 7, 2019 at 12:41 pm #3170168

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

February 8, 2019 at 11:24 am #3174779

martineG-3

One other thing, Marcos.
As you can see in the Portfolio Filter Gallery there are two galleries which display all projects in the backend (PROJECTEN and NIEUWS ITEMS).
The other galleries won't show the selected media for translation.

Has something gone wrong with the media translations?
Hope you can clarify things on how we should use the gallery and their translations.

Thanks in advance
Tony

February 8, 2019 at 12:58 pm #3175134

martineG-3

Hello Marcos,
Just now a new problem occurred.
WPML-String-translation and WPML-translation-management can't be upgraded to the new version.
I don't know why.
Tried to re-install te plug-ins, but I get the message the plug-in locations already exists.

Tony

February 8, 2019 at 5:43 pm #3176446

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Tony,

Thank you for the updates and for your patience. I took a closer look in the settings of your gallery plugin and here is the suggested workflow for translating your categories.

1 - In your WordPress Dashboard > Portfolio Filter Gallery Premium add a new gallery in the default english, dutch in your case and enter the contents of your gallery.

2 - Make sure the option 'Copy' is checked for the gallery custom fields for your current gallery shortcode id (see the attached screen_customer_23_01 screenshot). This will enable the current gallery content be copied for your secondary language galleries.

3 - Duplicate the gallery in the default language, dutch in your case for your secondary languages (see the attached screen_customer_23_02 screenshot) and update your page.

4 - Using the language switcher at the WordPress Dashboard top admin bar, change to your secondary languages in order to see the duplicated galleries. You should be now able to edit your galleries separatedly in order to translate the image captions, descriptions etc.

5 - You need to notice the shortcode you use to show the gallery in your pages has different ids in the different languages, so for your dutch page you need to enter the shortcode showed in the dutch gallery, for the english language you should enter the shortcode showed in the english gallery and so on.

Please, let me know if you need any additional clarifications regarding this approach. Have a nice day.

screen_customer_23_02.png
screen_customer_23_01.png
February 8, 2019 at 5:46 pm #3176472

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Tony,

As regarding the WPML plugins updates notices I would ask you to open a new ticket as we neded to keep things organized on a topic basis, it will help our customers to find solution for their issues in a topic basis. Thank you for your understanding, have a nice day.

February 11, 2019 at 9:13 am #3181543

martineG-3

Hello Marcos,

Thanks for the feedback. I followed your steps, but I guess I'm doing something wrong, because I can't seem to get it to work.

I've created a new gallery with four items, checked the custom fields, but I can't see the duplicated galleries.

What am I doing wrong?

Thanks for the help in advance.
Tony

February 11, 2019 at 7:21 pm #3185167

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look in your test gallery from your WordPress Dashboard > Portfolio Filter Gallery Premium > All Gallery and noticed you created a translation (clicked the plus icon) instead of creating a duplication of your original gallery, please, make sure to create a duplication of your original gallery, not a translation itself (see attached screenshot), the duplication feature will make sure all your gallery content is copied accross languages. Doing so, you can follow all the others steps of my previous reply. Please, let me know if you need any additional assistance, have a nice day.

screen_customer_28.png
February 12, 2019 at 9:26 am #3187480

martineG-3

Hello Marcos,
I followed your steps again.

Also made use of the duplication feature.

- I've created a gallery (TEST) in dutch
- Checked COPY in custom fields
- Duplicated it to english.
- re-opened it in english editor.

I get an empty gallery with the following message:
Warning: You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor.
Go back - Edit anyway - Open in Translation Editor

If I select images the english caption is shown, because I translated all the media win the media library. But I expected to see the images images already pre-loaded.
The gallery in my case is empty so I have to select all images again.
I'm puzzled with this.
Is it possible maybe make screen-movie-capture so I can check where I go wrong.
Thanks in advance.
Tony

February 12, 2019 at 5:33 pm #3190066

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Tony,

Thank you for the updates. I will do my best to provide you a step by step tutorial on how to achieve it, let's proceed this way:

1 - In your WordPress Dashboard > Portfolio Filter Gallery Premium click to add a new gallery in the default language (dutch). See attached screenshot step_01.png.

2 - Add some images and publish your gallery. See attached screenshot step_02.png.

3 - Check the option 'copy' for your gallery custom field (see attached screenshot step_03_01.png) and update your gallery (see attached screenshot step_03_02.png)

4 - Now click to duplicate your gallery for your secondary languages (see attached screenshot step_04_01.png) and update your page again for the duplication feature to take effect (see attached screenshot step_04_01.png).

5 - Using the top admin bar language switcher change to your secondary language in order to edit the duplicated gallery (see attached screenshot step_05_01.png) when prompted to edit the translation, click the 'edit anyway' button (see attached screenshot step_05_02.png)

6 - Now you should be able to edit your duplicate galleries, this way you can for example translate the gallery text such as image captions, descriptions and so on (see attached screenshot step_06.png). Don't forget to always click the update button to save your changes.

7 - When you are done with your galleries creations you can now paste the different shortcodes for your translated pages, for example: for your dutch pages you should copy and paste the dutch gallery shortcode, for the english pages the english gallery shortcode and so on. You'll notice the shortcodes are different for the duplicated galleries. (see attached screenshot step_07.png)

Please, let me know if you still need any additional clarifications. Have a nice day.

step_07.png
step_06.png
step_05_02.png
step_05_01.png
step_04_02.png
step_04_01.png
step_03_02.png
step_03_01.png
step_02.png
step_01.png
February 14, 2019 at 10:56 am #3198942

martineG-3

Hello Marcos,

Thanks for your time and effort in providing the step-by-step explanation.
I followed your steps (as before) and are able to make the galleries.

However what I don't understand is that the translations are not within WPML.
Also with step 4 you have to slect the wanted images again. Why aren't they already listed in the duplicated gallery. Now you have to make the galery three times.

Step 7 - I pasted the codes, but again you have to leave the WPML. Following changes will not synchronize.

Anyway, thanks for your effort. I understand now how we can workaround the issue.

Tony

February 14, 2019 at 4:27 pm #3200937

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Tony,

Thank you for the updates. Regarding the step 04 you need to make sure to click the update button after the duplication process, this will ensure your images will be copied to your duplicated page with no need to manually select them again, this is how I proceeded and it worked properly.

regarding the step 07 you said the following: "I pasted the codes, but again you have to leave the WPML. Following changes will not synchronize." what do you mean with "you have to leave the WPML"? I couldn't understand that sentence, the correct workflow is: Copy the gallery shortcode and paste it on a page, there's no workaround for that, neither a way of the shortcodes to be automatically copied to your gallery pages, this is how the plugin works. Please, let me know your points and I will give you the full details. Have a nice day.

February 15, 2019 at 9:32 am #3203716

martineG-3

Hello Marcos,

It seems to be working now.
I'll delete the French and English versions of the galleries and start from scratch following your steps.
Images seem to be copied now.

What i meant wth "leaving WPML" is what you showed in image step_05_02

For using the correct gallery code you have to manuallly paste the code in the english or french version. It cannot be done by using the WPML editor. See image. As you can see the (code) field for the gallery isn't showing there for translation.

But I guess with this plugin you have to edit the pages separately.

Thanks for all you help.
Sorry for the inconvenience.
Tony

page-to-translate.jpg