This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Alejandro 5 months, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
January 8, 2019 at 1:01 pm #3066838

tobiasS-20

Two more question

1.) How can I setup a language based Slider Revolution Slider? Currently there is no Slider on the german page.
2.) How can I change a video? On the german page, there is currently the english video, but we like to have a language based video.

January 8, 2019 at 1:34 pm #3067095

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

First of all, i suggest you watch this guide: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

Once you get to translate the sliders by language you will be able to select videos, texts and pretty much everything for the new slider.

If you have followed the guide provided already and it doesn't work as expected, then let me know what happens and i can try to help you.

Regards,
Alejandro.

April 1, 2019 at 2:10 pm #3508861

tobiasS-20

So I've translated the Sliders content, but I see no opportunity to show it on the german page. When editing, there is no checkbox or anything else and it doesn't appear automatically

April 2, 2019 at 6:34 am #3514065

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

There must be something wrong, since it should show automatically if the slider was translated. I suspect this could be a memory issue bu i would need to confirm it.

To continue, I'll need temporary access to your site.

I have just activated the appropriate boxes for the credential information i need from you. they are private so only you and i will be able to see them.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the fields mentioned above.

Afterwards, please point me to the slider in question and where in the site is it integrated.

Let me know how it goes.

April 15, 2019 at 8:36 am #3611153

tobiasS-20

Hello,

did you have the chance to oversee the problem?

April 15, 2019 at 10:06 am #3612079

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I believe the slider has been set using the "Brooklyn Metapanel", right?

Below the metapanel you'll find a section called "Multilingual Content Setup". In there you'll find several custom fields, find and set to copy the fields that you want to send to the other pages. in this case the field is called "ut_page_hero_custom_shortcode" but i believe you have to setup all the other "ut_page_hero" as well.

Once you finish, click the "apply" button at the end of that section.

Last but not least, update your page (add a character to the title or something similar and click the "Update" button) and proceed to update the translation as well (you should get a spinning arrow icon, that means the update is available for the translation language).

Try it out and let me know how it goes.

April 25, 2019 at 10:57 am #3681371

tobiasS-20

The settings you've mentioned have already been made but there is no change.
The Slider is still not visible.

April 26, 2019 at 8:00 am #3688625

tobiasS-20

Do I have to open another thread?

April 26, 2019 at 3:26 pm #3692015

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

There's no need to open another thread. i'm looking into the problem as we speak.

I'll post an answer as soon as i find what's causing this issue and hoepfully how to solve it.

April 26, 2019 at 4:29 pm #3692295

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I mentioned that you might've had to configure other settings as well and it seems that's what was missing. i set all the remaining fields as "copy" so it would correctly copy the settings and now i can see the slider in the german page as well.

Could you check and confirm, please?

Thanks in advance.