This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 24, 2019 at 5:27 pm #3675575

mauroP-22

Hi Sir,

How to translate strings/plugins?

Thank you very much!

April 25, 2019 at 8:34 am #3680121

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Could you please review the documenation about translating strings and let me know if this helps to translate the strings?
https://wpml.org/documentation/getting-started-guide/string-translation/

Look forward to your reply.

Thanks

April 26, 2019 at 5:45 pm #3692701

mauroP-22

Hi, I have translated the strings I need in Italian after I have upload the .po files with wpml, I have created a new page for the second language (italian) but wend I change from English in Italian the book now page is empty!

Thank you!

April 29, 2019 at 8:30 am #3701103

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have created a new page for the second language 

Did you create a new page as a translation? It's not needed, you can add a translation from the default language page itself, could you please try this?

More details on translating content here: https://wpml.org/documentation/translating-your-contents/

Look forward to your reply.

Thanks

April 29, 2019 at 2:30 pm #3704415

mauroP-22

Hi, i have translated a plugin and uploaded the .po files but now, after i have cancelled the page in Italian show me 404 error!
May I send to you a private msg with credidentials to take a look what is wrong?
I need to translate book now page in Italian!

Thank you very much!

April 30, 2019 at 7:46 am #3708839

mauroP-22

Hi, how much i need to wait for your response?

Thank you

April 30, 2019 at 7:48 am #3708865

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sorry for the delay in replying.

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

April 30, 2019 at 9:42 am #3710165

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

While trying to edit the Book Now page I can see the following message" This translation is currently in the trash. You need to either delete it permanently or restore it in order to continue."

So could you please restore the page or delete it and let me know if that helps? If you delete the page you will need to retranslate the page again, to make it work perfectly.

Look forward to your reply.

Thanks

April 30, 2019 at 11:26 am #3710651

mauroP-22

Hi, I have restored the page.

Thank you

April 30, 2019 at 11:39 am #3710679

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see there are lots of Book Now page, which one is the correct one?

Also, I can see that you have used "Book Now" Booking Form on the English book now page and can see Book Now Booking form is not translated at all, so could you please translate the Book Now Booking form to the secondary language accordingly?

Once you translate the form, go to translated book now page and select the default language form there, the translation should load automatically.

Look forward to your reply.

Thanks

April 30, 2019 at 11:47 am #3710717

mauroP-22

Hi, I have more similar forms book now in English, for every form I have a page in English.
Now I need for every form the Italian language and I have translated in Italian the forms, after I have uploaded the .po files for forms .
But the translation thing show.

Thank you

April 30, 2019 at 11:51 am #3710723

mauroP-22

I have translated the front end for the forms, I have created a new book now form and I have set a Italian language.
After I have created a new page for the Italian book now forms.

May 2, 2019 at 4:12 am #3721537

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Now I need for every form the Italian language and I have translated in Italian the forms, after I have uploaded the .po files for forms .

I understand that you have added the .po files for the forms accordingly, but since the form is created using post format basic translating it from the backend is also necessary, so could you please follow the below steps:
- Go to hidden link
- Click the + Icon and translate the form into the secondary language
- Now go to the page and select the forms accordingly.

Let me know if this helps.

Thanks

May 2, 2019 at 6:02 am #3721967

mauroP-22

Hi , I have made like you told me but still not work.
Now the page in Italian it is empty.
What to do?

Thank you

May 3, 2019 at 5:36 am #3730947

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the issue, I tested few settings but it didn't work, so I am currently creating a duplicator package on your site, so I can replicate your site on my localhost and test further.

I will update you as soon as possible.

Thanks

The topic ‘[Closed] How to translate strings/plugins?’ is closed to new replies.