This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by rolfL-7 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 21, 2019 at 9:01 am #3853413

rolfL-7

Tell us what you are trying to do?

I want to translate "Privacy Policy" into portuguese language.

Is there any documentation that you are following?

I did not find any documentation for that. I tried translation in WPML string translation but no effect.

Is there a similar example that we can see?

Yes, at hidden link

What is the link to your site?

hidden link

May 21, 2019 at 9:27 am #3853559

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Please follow the below steps to fix the issue:
1) Go to Dashboard->pages and translate the Privacy policy page, the translated title will appear on the login page.

2) Copy the following code in WPML->Settings -> Custom XML configuration

<wpml-config> 
<admin-texts>
<key name="wp_page_for_privacy_policy"/>
</admin-texts>
</wpml-config>

3) Once you place the code there, go to WPML->Settiings -> Multilingual content setup and refresh the page.

To find out more, https://wpml.org/documentation/support/language-configuration-files/

4) Now go to string translation, you will see a string with wp_page_for_privacy_policy name,

5) The value will be page id of the privacy policy page, so enter the translated page id.

Let me know if this helps.

Kind Regards,
Shekhar

May 21, 2019 at 10:05 am #3853965

rolfL-7

Hi Shekhar,

thank you for quick replay.

Steps 1, 2, 3, 4, and 5 executed but no effect.

Confirmed page id of translated page is 5289.

Best regards
Rolf

May 21, 2019 at 10:12 am #3854153

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you first change the language of the string to English and add the translation? This will fix the issue.

1) Choose the string from Strings List
2) Click on *Change language of selected strings* button
3) Choose *English* from *Change the language to the:* drop-down box
4) Save the changes and confirm String's Language is modified
5) Then you can translate the String to other languages

Let me know if this helps.

Thanks

May 21, 2019 at 10:29 am #3854299

rolfL-7

Hi again,

have chosen *English* from *Change the language to the:* drop-down box and saved but language is still portuguese.

May 21, 2019 at 10:38 am #3854469

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Would you mind providing me login details so I can quickly check this? To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

May 21, 2019 at 11:33 am #3854833

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The string that's showing on the login page seems to be added by some plugins, could you please let me know which plugin/theme is adding the text there along with checkbox?

Look forward to your reply.

Thanks

May 21, 2019 at 12:06 pm #3854983

rolfL-7

Hi again,

the responsable plugin might be Cookie Notice.

Rolf

May 21, 2019 at 12:16 pm #3855005

rolfL-7

Hi again,

I discovered now the text in Enfold theme GPRD settings and changed it there to english.

But how can I translate now to other languages?

Rolf

May 21, 2019 at 12:18 pm #3855013

rolfL-7

Thank you, I think the issue is almost solved.

May 22, 2019 at 3:27 am #3860485

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Glad to know the issue is resolved, would you mind sharing the steps you performed so it can be helpful for similar users in future?

Kind Regards,
Shekhar

May 23, 2019 at 8:30 am #3872543

rolfL-7

Hi Shekhar,

I did not find out how to translate customizations in enfold child theme.

Dashboard -> Enfold Child PT-PT -> Privacy and Cookies

How can I translate the string "Privacy Policy" to further languages than portuguese?

Best regards
Rolf

May 23, 2019 at 12:16 pm #3874933

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

When using the Enfold theme, you need to set the theme options for each language. Please go to Enfold -> Theme Options. At the top left, you should see where you can change the language. Please set the correct settings for your default language and your secondary language(s) and then the text.

Let me know if this helps.

Thanks

May 23, 2019 at 12:56 pm #3875459

rolfL-7

Hi Shekhar,

yes, that helped. Thank you very much!

Best regards
Rolf

May 23, 2019 at 12:58 pm #3875513

rolfL-7

My issue is resolved now. Thank you!

Best regards
Rolf