If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Ahmed Hussein Karam 1 year, 3 months ago.

Assigned support staff: Ahmed Hussein Karam.

Author Posts
August 14, 2018 at 6:46 am #2642425

Makarand Mane

I'm trying to do translation of visual composer content. But I cannot see content in Page translation option.

August 14, 2018 at 11:13 am #2643082

Ahmed Hussein Karam

Hi, thanks for contacting WPML support forum

It seems that you are using custom shortcodes that are not configured in the Visual Composer configuration file, so I will need to take a closer look to see the structure of your content, so please give me an access to your site WordPress admin account to be able to help you. It may also help if you give me an FTP access to your site.
Note that this access is private and will be for support team only, you can read more about this here: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

For more information about the configuration files, please check this: https://wpml.org/documentation/support/language-configuration-files/

Kind Regards,
Ahmed Hussein.

August 14, 2018 at 4:38 pm #2644029

Ahmed Hussein Karam

Hi, thanks for reaching out again.

As I told you, there are some shortcodes that need to be configured in the language configuration file. I fixed the issue for you by following these steps:

1- I went to WPML > Settings and switched to the "Custom XML Configuration" tab
2- I found that you already added the shortcode "themestudio_title", so I just added the attribute "title"
3- I added the shortcode ts_service_image with the attribute ts_service_image and clicked "Save"
4- I opened the page in WordPress, made a small change (e.g. added an additional space character in the page title) and clicked "Update"
5- Finally, I opened the translation editor again and found that everything is now translatable

Similarly, you can add any other shortcodes according to our documentation here: https://wpml.org/documentation/support/language-configuration-files/

Please let me know if your issue is fixed.

Kind Regards,
Ahmed Hussein.