Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Nohemi 1 year, 5 months ago.

Assigned support staff: Bobby.

Author Posts
July 12, 2018 at 10:29 am #2489256

Nohemi

Tell us what you are trying to do?
- I want that when i change a media caption in a language, it will be copied in all languages.

For example, i have a french image. If I change its caption, i want this change the english caption with same value. I don't want to translate captions.

How to do it ?

Is there any documentation that you are following?
https://wpml.org/documentation/getting-started-guide/media-translation/
https://wpml.org/2018/06/important-changes-in-how-media-translation-works-since-wpml-4-0/

July 12, 2018 at 8:12 pm #2490874

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Please go to WPML->Settings-> Post Types Translation -> "Media" and set it to Translatable - use translation if available or fallback to default language

this will allow you to use the same media set within your default language through all your languages

ex. you have a site with French and English and Spansh. (French is default)

media set in the French language will show in the rest with the same information .

July 13, 2018 at 7:40 am #2491606

Nohemi

I forgot to say : images are in an ACF gallery field. (this custom field is set on "copy")

With your settings there is no difference. On the english page, there is always the (empty) english caption of the english image.

I can send you an access to the website if you want.

July 13, 2018 at 5:47 pm #2492601

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

In this case i believe you will need to duplicate it over or translate it over manually but i can take a closer look to verify

private field has been enabled

July 17, 2018 at 5:12 pm #2530689

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Please go to my profile and edit it to enable for me to be able to view "hidden languages"

additionally please provide me with the exact steps i need to take to replicate the issue

thank you !

July 18, 2018 at 7:36 am #2531834

Nohemi

I have changed your profile setting (but normally your are administrator so you have all the rights).

I have edited the private post with some new informations.

July 19, 2018 at 6:51 pm #2535382

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

you can find the WPML Media settings as they were before the update within WPML->Settings->Bottom of the page "Media Translation" please run them and let me know your results

i have test this on my local enviroment and it seems to be working as expected.

also test this on your site with this page
hidden link

i created one in French and duplicated it over to German.

the title carried over.

July 20, 2018 at 11:02 am #2536665

Nohemi

Thank you but you have duplicated a page so yes there is the same caption on the two page but have you tried to add the german image after translating the german page (no duplicating) ? I don't want all page content to be identical, just the image.

I want only that when i change the french caption of an attachment, it updates the german caption with same value or the possibility to have only one attachment for all language as was the case before.

>you can find the WPML Media settings as they were before the update

Precisely i didn't use WPML Media. Before the update, there was only one attachment per file so no problem : i added the image to the acf french field. The field is copied by WPML : same value so same attachment and same caption in German.

But now : even without the WPML media plugin, there is one attachment per language for one file so when the field is copied, WPML "translate" the attachment ID so it is not the same attachment and the caption is different.

July 20, 2018 at 5:52 pm #2565410

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Please go to WPML->Settings->Bottom of the page "Media Translation" run the WPML Media and let me know your results

There have been quite a few changes on how WPML Media works since the latest update.

WPML Media now allows you to translate the Media itself therefore one media in one language and the secondary can have a seperate media set as the translation of the media.

therefore for now you need to duplicate the media through the settings , as it has changed from before in the previous versions.

July 24, 2018 at 8:05 am #2572466

Nohemi

> Please go to WPML->Settings->Bottom of the page "Media Translation" run the WPML Media and let me know your results

No difference. At the same time, my media example was added after the update so it is already duplicated.

> WPML Media now allows you to translate the Media itself therefore one media in one language and the secondary can have a seperate media set as the translation of the media.

Therefore for now you need to duplicate the media through the settings , as it has changed from before in the previous versions.

Ok if i have a french media and i duplicate it, all languages will get the same caption but, if later, i want to update the caption, there is no solution to keep it synchronized between languages ?

July 24, 2018 at 12:26 pm #2573754

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Hello, Bobby is off for today so I am stepping in to help out. We just released a new version of WPML, version 4.0.5. Please update to this latest version and let me know if the image caption issue is now resolved.

July 24, 2018 at 3:11 pm #2575468

Nohemi

Hi Lauren,

there is a slight improvement : when the german caption is empty and that i change the french caption, the caption is copied to german (good :)) but after if i change the french caption a new time, the german caption stay to its first value.

If i empty the German translation then i rechange the french caption, it is copied to German.

So to resume, the french caption is copied only if the German caption is empty.

It is better but i would like that the french caption override any German caption value.

July 25, 2018 at 4:36 pm #2581088

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

i am glad to hear that the new version of WPML has helped with this.

At the moment we do not have a standard option within WPML that will set French captions to override the German ones

this could be possible with custom work , which unfortunately we cannot provide within the forum.

additionally i can bring this up as a feature request for our developers to see but as of right now the WPML media seems to be working as expected , due to the caption being filled in already that is the reason why it is not being overriden the second time.

July 26, 2018 at 9:37 am #2583598

Nohemi

Maybe, because of the last update (because i have tested at first), if i uncheck "When uploading media to the Media library, make it available in all languages" option and set translation of medias on "Translatable - use translation if available or fallback to default language", it works !

The medias are not duplicated on upload and they are available in all languages. So i can use the same captions in all languages like before the major update.

Thank you for your help.