This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to translate advanced custom fields separately by using WP All Import

Solution: - First import the fields in primary languages properly. - Set the fields translation preferences accordingly. - Import the fields in secondary languages using connector id, don't add any fields items to the system fields.

Relevant Documentation: + https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/ + https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

This topic contains 22 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 month, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 31, 2019 at 12:51 pm

fabioC-5

Hi,

The problem:
When I import my custom posts (neutral products) in english by using WP All Import all the advanced custom fields contents are in the default language (italian) !!

The advanced custom fields of my custom posts are created by using the Advanced Custom Fields plugin.

I got two languages: italian (default) - english

What I need:
Each custom posts in english shoud have the advanced custom fields with english content.

The question:
How can I tell to WPML to translate each advanced custom field separately from italian?
I don't want the content from the italians custom posts...

WP All Import:
I created two different import file (csv): one in italian e the other one in english.
You can find both files .csv by access to my ftp server (root folder).

Each import works great.
The posts are correctly related from each other.
All the wordpress native fields and custom fields works properly.
The problem is only related with the advanced custom fields in english.

I hope I was clear.

Please let me know

September 2, 2019 at 3:54 am #4494275

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Have you marked those fields are "Translate" and it's system fields as "Copy" before importing? https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Is the import working properly for the default language?

Look forward to your reply.

Thanks

September 2, 2019 at 10:43 am #4496359

fabioC-5

Hi,

I set my advanced custom fields via PHP (hidden link) so I don't know where to specify the "Translate" option for WPML.

By the way I also tried to test the import by using the ACF Admin (all advanced custom fields were set to "Translate") but It doesn't work at all... Same problem. All the english custom posts have the fields in italian.
Today I notice another issue. The advanced custom field gallery is empty (the english one).

"Is the import working properly for the default language?"
Yes. It works properly. All fields are ok.

September 2, 2019 at 10:56 am #4496407

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Go to WPML->Settings->Custom Field translation search for those fields and mark it as your choice and import again. https://wpml.org/wp-content/uploads/2019/02/Setting-the-custom-fields-transaltion-prefrrence-from-the-WPML-Settings-page.png

Please import only 1 page to test the results once.

Let me know if this helps.

Thanks

September 2, 2019 at 3:28 pm #4498295

fabioC-5

Hi,

I don't have the "Custom Field" section on my WPML Settings.
You can see all my plugins and my WPML settings by following this link:
hidden link

I installed all the latest plugins versions available and I got the latest WP Version.

PS: by the way I also sent you my credentials for my ftp area so you can see by your self.

September 3, 2019 at 3:37 am #4500925

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I noticed that you aren't using WPML translation management, it's a required plugin for translating ACF with WPML, so please install it. Once you install it the custom fields section will be there in WPML->Settings.
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/#requirements-and-installation

Let me know if this helps.

Thanks

September 3, 2019 at 6:27 am #4501521

fabioC-5

Hi,

I installed the WPML translation management plugin. I found the section you mentioned and I set as you suggested (I also attached my settings). The result is always the same. All english custom fields are in italian.

September 3, 2019 at 8:31 am #4501997

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Did you imported the product again? Can you provide me the import id so I can test?

Look forward to your reply.

Thanks

September 3, 2019 at 9:54 am #4503155

fabioC-5

Hi,

Yes, I imported the product again.
The import ID is 1 (for italian) and ID 2 (for english)

September 4, 2019 at 3:55 am #4508261

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

I would need your permission to delete imports, posts to debug this issue further, is it ok If I performed it on the demo site you provided.

Look forward to your reply.

Thanks

September 4, 2019 at 5:15 am #4508323

fabioC-5

Hi,

I give you my permission to do whatever you need to solve my issue.
It's just a demo site.

September 4, 2019 at 5:40 am #4508409

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am testing the issue but when I am on the last step I always receive page not found issue, I even deactivated WPML and can see the same issue, can you check if you can proceed to step 4 with a new import?

Look forward to your reply.

Thanks

September 4, 2019 at 3:21 pm
September 5, 2019 at 4:40 am #4515421

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Is the URL same for the cloned site?

Also could you provide feedback on my last reply too?

Look forward to your reply.

Thanks

September 5, 2019 at 7:24 am #4516095

fabioC-5

Hi,

"Is the URL same for the cloned site?"
I don't understand what do you mean...

I cloned the site from "wpdemo.fabiochiarato.com" to the new server "ilsa.mystage.vedsto.com" (by using the duplicator plugin) in order to solve the error "page not found" that you got.
I did that because I suspected it was a server related issue...

I also checked if there was the "page not found issue" on the new server and It seems ok to me.
Not 404 issue found so you can proceed to test.

I hope I was clear.