This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am getting this Sistrix error about missing hreflang on my website. --Sistrix Error--- Hreflang back-link is missing The destination page for the Hreflang link does not contain the reverse links. Solution: The cause of the issue is the hreflang setting in WPML -> Languages -> Edit Languages.

To solve the issue you need to change the hreflang value for German from "de-DE" to "de" - Do the same for all the other installed languages (eg. "en" instead of "en-US") Relevant Documentation: https://wpml.org/documentation/support/adding-hreflang-wordpress/#check-your-hreflang-settings-and-make-sure-they-are-as-you-intend-them-to-be

This topic contains 4 replies, has 3 voices.

Last updated by Vincenzo 1 year ago.

Assigned support staff: Vincenzo.

Author Posts
September 7, 2018 at 8:00 am #2713611

bertG-2

Hello,

I need help with href-back links. As I am getting this sistrix error about missing hreflang on my website gosign.de. All the href links are generated by WPML automatically so I request you to add the back links too.

--Sistrix Error---
Hreflang back-link is missing
The destination page for the Hreflang link does not contain the reverse links. The configuration is therefore invalid. The Hreflang-integration needs to be bi-directrional, otherwise Google may ignore the integration.

September 7, 2018 at 8:02 am #2713644

bertG-2

Here is a screen shot

September 10, 2018 at 10:58 am #2719674

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

I tested your website with this tool: hidden link

It seems like the cause of the issue is the hreflang setting in WPML -> Languages -> Edit Languages.

Can you please change the hreflang value for German from "de-DE" to "de"?
- Please do the same for all the installed languages (eg. "en" instead of "en-US")

Please let me know if this solves the issue or if you need further details.

Thank you

Related documentation:
https://wpml.org/documentation/support/adding-hreflang-wordpress/#check-your-hreflang-settings-and-make-sure-they-are-as-you-intend-them-to-be

October 1, 2018 at 1:44 pm #2778329

robinS-3

Hi,

I get the same errors from Sistrix. We already use "de", "fr" and "x-default" (for en).
Is there a other solution to fix this problem?

Thanks in advanced.

Best Regards
Marc

October 1, 2018 at 2:08 pm #2778381

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi Marc,

this ticket is closed.

May I ask you to open a new ticket?

You can do it from here: https://wpml.org/forums/forum/english-support/

Thank you