This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Itamar 2 months ago.

Assigned support staff: Itamar.

Author Posts
August 11, 2019 at 4:40 pm

gulshanK

Hello Folks!
Hope you are doing great!

I published an article in English. I clicked "Add translation to Hindi" and wrote a new post manually in the Hindi language.

I checked my Hindi permalink source code. I am shocked, it is missing link back to English language in the hreflang.

Ref: hidden link

Thanks & Regards,
Gulshan

August 12, 2019 at 11:26 am #4380369

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Gulshan,

thanks for contacting us.

It's true that the hreflang for all languages should show up, but at the moment I don't have enough information to say why this is happening.

I checked your site and I see for example in the About page the hreflangs are both appearing.
Could you try using the WPML translation editor and see if the issue still exists? Or could you try to FULLY translate the post before publishing it? In your video you only translated the title.

August 12, 2019 at 1:01 pm #4381051

gulshanK

Hello dear,

Thanks for your kind response.

" could you try to FULLY translate the post before publishing it? In your video you only translated the title."

Okay, I have tried this second time adding Title and Content both in respective languages. Unfortunately, corresponding hreflang is still missing. You can try to repro from your end also with my login credentials.

Video: hidden link

Please check.

Thanks & Regards,
Gulshan

August 12, 2019 at 1:28 pm #4381297

gulshanK

UPDATE
*******************
With Classic Editor everything seems fine. This problem is happening only with Gutenberg editor. Please check with the concerned team.

August 12, 2019 at 2:37 pm #4381667

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Gulshan,

I checked what you experienced in a fresh installation, but I didn't experience this with Gutenberg.

It seems I can't access your site, so could you please add WPML debug information? You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

Please ensure WordPress, WPML and all plugins are updated. Also please try a compatibility test:
- backup your site
- disable all plugin except WPML and its addons
- switch to a default theme like TwentySeventeen
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again
- lastly, reactivate your theme

August 13, 2019 at 9:57 am #4386827

gulshanK

Can I have e-mail support? It is very inconvenient to talk here because I am not able to add debug information.

August 13, 2019 at 9:59 am #4386837

gulshanK

I have tried all things which you mentioned. Still it doesn't work.
hidden link

August 13, 2019 at 12:12 pm #4387787

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Laura is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

By looking at the last video that you shared, it seems like the problem is different. The issue is not the there are missing hreflang tags. But the issue is that once you create a translation for a post, it is not connected to the original post. Please see the attached screenshot from your video. The hreflang is then only pointing to the same post because there is not connected translation. I've tried to take the steps that you take while translating a post and I couldn't replicate this issue on my tests site.
Can you see that this is the issue on your site?
Are all posts that you translate not connected to the original post?

I'm sorry, but we don't have e-mail support in our forum. The communication can be done here in this thread. It is weird that you cannot add the debug information.
Can you please specify what is not working for you?

I also tried to access your site, but it does not work for me. I get the ERR_TOO_MANY_REDIRECTS message. Please see the attached screenshot.
Can you please fix this issue so I can continue to debug this issue?

Thanks,
Itamar.

The topic ‘[Closed] hreflang is missing for alternate version’ is closed to new replies.