This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Alejandro 3 months, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
July 4, 2019 at 8:17 am #4141131

adrianF-9

Please. I also need help with the hreflang code.

The code does not appear on the urls:

hidden link

hidden link

July 4, 2019 at 8:20 am #4141167

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Ok, so could you explain what is the problem (where can i see the problem, etc) and if you're only facing this issue on these 2 pages or on other ones?

I'll proceed to check it out and try to see what's going on.

July 4, 2019 at 8:59 am #4141453

adrianF-9

I have some problems when I index the website to Google.

Search Google Console said that it cannot index the pages:

hidden link

hidden link

But these pages are translations of the pages in english.

I checked the code of the pages yesterday and the "hreflang" tag did not appear (it does for the english version).

However, I checked it again this morning and I saw the hreflang tag in the code of the pages. And later on I did it again and the tag didnt appear. Quite confusing.... Why does they appear just sometimes?

What does depend for the tag to appear? Does the tag dissapear if I disable the plugins "WPML Management" or "WPML String"?

You can see the codes on the following links:
view-source:hidden link
view-source:hidden link

July 4, 2019 at 12:45 pm #4143299

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I think that could be happening because your site is not meeting the minimum requirements.

Please add the following code in your wp-config.php file, right after the database information lines of code:

define('WP_MEMORY_LIMIT','128M');

Then let me know if the problem keeps happening, because i opened it once every hour and the hreflang was always there but if at any moment any other thing was running (maybe you had updated a page, maybe you had translated something, etc) that could've temporarily increased the memory use and maybe that's why the hreflang didn't appear.

I t would also be a good idea if you could enable your debug.log which will register any error on the server side coming from a plugin or theme.

To do that please follow the instructions mentioned on this page: https://wpml.org/documentation/support/debugging-wpml/

If you encounter the issue again then go to the wp-content directory and you might find the debug.log there, that will tell you if there's an error being thrown by WPML or any other plugin or theme.

Regards.

July 4, 2019 at 1:39 pm #4143959

adrianF-9

I followed your advices and I will check if the hreflang tag appears or not.

Thanks!

July 4, 2019 at 1:47 pm #4144029

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Perfect, let me know how it goes!

July 8, 2019 at 7:50 am #4159623

adrianF-9

I checked it again today and it still misses the hreflang tag.

Is there anything else we can do? Can we write it manually?

July 8, 2019 at 11:07 am #4161681

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Could you give me access to your site again? and can you take another screenshot again when you see the problem, there must be something wrong, indeed, but i can't replicate the problem i have tried hundreds of times to replicate the problem and it always works and shows the hreflang.

I activated the fields so you can add your credentials safely and privately (the last ticket is closed so the system erased your data to maintain your privacy and safety)

Regards.

July 9, 2019 at 9:53 am #4169385

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I think the problem is that Yoast Multilingual is not working properly and that's happening because the requirements for that glue plugin is not being met as you can check here: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

You basically need to activate String Translation and Translation Management and that should fix everything.

However i advise that you monitor the issue and let me know afterwards if it happens again.

Thanks in advance!

July 9, 2019 at 9:55 am #4169399

adrianF-9

Hi Alejandro,

I manage myself in english and spanish.

I guessed what you said in italian, but, Could you please explain it again in some of these languages?

Im from Spain, so choose the language you feel more comfortable.

Thanks,

July 9, 2019 at 12:24 pm #4170673

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm sorry for that mistake!

I translated the text into English but i'm also a Spanish native speaker so if you want to continue in Spanish, just say so, it's fine by me, either way, as well.

July 9, 2019 at 1:17 pm #4171075

adrianF-9

Podemos seguir hablando en español si le parece bien.

No sé si a otras personas les sucede igual, pero, cuando activo esos dos plugins, la página suele perder la conexión constantemente.

July 9, 2019 at 1:44 pm #4171347

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sinceramente eso no debe pasar, pero si me das acceso FTP (para poder restaurar la página si pasa lo que mencionas) puedo intervenir e investigar cuál es el problema.

Saludos.

The topic ‘[Closed] Hreflang issue’ is closed to new replies.