This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 6 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
March 1, 2019 at 9:25 am #3259199

dominikC-4

I have a website with few languages, when i am on taxonomy in different language then main (English), i have not valid rel alternate links.

<link rel="alternate" hreflang="en-us" href="hidden link" />
<link rel="alternate" hreflang="da-dk" href="hidden link" />

When i am on english version everything is ok.

<link rel="alternate" hreflang="en-us" href="hidden link" />
<link rel="alternate" hreflang="da-dk" href="hidden link" />

Link to a page where the issue can be seen:
hidden link

If i go to product hidden link
I also have valid rel aternate links.

I have this problem only on taxonomy.

Configuration of taxonomy:
hidden link
hidden link
hidden link

March 4, 2019 at 9:21 am #3267616

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,
Welcome to our forum, I will be handling your ticket.

I would like to ask a few information for a detailed understanding of the issue.
1) Have you changed the default language of your site in recent past?
2) Have you changed the Default slug language of Collections taxonomy?
3) Backup your site and database Goto WPML > Support > troubleshooting
4) On troubleshooting page under Clean up section click on the button
  - Clear cache in WPML
 - Recreate ST DB cache tables

Let me know if that helps.

Kind regards
Raja

March 4, 2019 at 8:18 pm #3270569

dominikC-4

1) Have you changed the default language of your site in recent past? NO
2) Have you changed the Default slug language of Collections taxonomy? NO
3) Backup your site and database Goto WPML > Support > troubleshooting DONE
4) On troubleshooting page under Clean up section click on the button DONE
- Clear cache in WPML DONE
- Recreate ST DB cache tables DONE

I still have the same problem.

March 5, 2019 at 5:54 am #3271758

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

Kind regards
Raja

March 15, 2019 at 2:47 pm #3354801

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

The issue might be due to memory limitations, Please follow the below recommendation

#1
Please increase the PHP Memory Limit (your current setting is 64M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:


/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

#2
Please increase the PHP Max input vars to 3000, follow the link below if you are unsure how to do it, or you can simply request your hosting provider to assist you
hidden link

Let me know the results.

Kind regards
Raja

March 27, 2019 at 10:07 am #3469431

dominikC-4

Nope. We still have the same problem. In default language everything is ok, but if you switch language, hreflangs are not correct.

March 27, 2019 at 2:59 pm #3472303

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I can still see the memory limit is 64 MB can you please fix it and increase the limit to 256M as mentioned before.

Please clarify whether the theme is custom made? How the custom post type product and collections taxonomy is added it is through the theme are from a plugin?

Is it possible for you to do the following test?

-Back up your site first
-Deactivate all the plugins that are not related to WPML,
-Switch for a moment to a WordPress default theme like Twenty Fourteen. ( If the collection taxonomy is theme related skip this step )
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Thanks for your cooperation.

Let me know your results, please.

Kind regards
Raja

April 1, 2019 at 2:09 pm #3508857

dominikC-4

No. I have good values in php. I also disabled plugins without one, where is created custom post type, and nothing.
hidden link

April 2, 2019 at 5:41 am #3513949

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

If you can provide a copy of your wp-content folder and database that would help as well. Please compress the copy of the wp-content folder and upload it to g-drive or dropbox and share the link.

You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

This will be helpful to debug the issue in a local environment without disturbing your setup and give us complete access to your site

Kind regards
Raja

April 12, 2019 at 1:39 pm #3599557

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Thanks for the files, It's quite heavy to download, I am cleaning up some resources to test your clone on the local environment.

In the meantime please try the latest version of WPML plugin 4.2.5, Clear site cache or try disabling cache plugin.

Update the Collections slugs and resave the permalinks. Let me know if that helps
Kind regards
Raja

The topic ‘[Closed] Hreflang problem’ is closed to new replies.