This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by stephanieM-9 3 months ago.

Assigned support staff: Riffaz.

Author Posts
July 17, 2019 at 3:25 am #4225587

stephanieM-9

Hi there,

I turn on the hreflang option for SEO

Under the main language: hidden link --hreflang tag working fine
Under secondary language: hidden link hreflang tag not working

If you need server/admin login, it should be same as my last support ticket.

Many thanks,

July 17, 2019 at 5:34 am #4225971

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

This is expected.
These are the hreflang links that WPML generates (see the complete explanation of hreflang tags for multilingual sites) Your content has a lot of links going to different pages and off-site. This list of links tells Google what translations exist for any page. With that list, Google can distinguish between ‘regular’ links to other content and links to translation.

You may be interested in this articles about multilingual SEO:
https://wpml.org/documentation/support/multilingual-seo/
https://wpml.org/2013/07/how-to-do-multilingual-seo-for-wordpress-sites/
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Specifically : You may be interested in this articles about multilingual SEO:
https://wpml.org/documentation/support/multilingual-seo/#how-to-apply-good-seo-to-multilingual-sites

Let me know if you need anything else regarding this.

Regards,
Riffaz.

July 17, 2019 at 6:20 am #4226081

stephanieM-9

Hi

Thanks for your reply. Unfortunately, none of these articles mentioned how to translate the hreflang tag. I know how translate SEO meta tag. I just need some help to get the correct hreflang tag on the secondary language.

July 17, 2019 at 7:05 am #4226295

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I think I did not explain clearly.

This is your default language site: hidden link
This is your second language site: hidden link

As you see there are hreflang tags in both languages site for both languages.
This is how the WPML works and this is normal.

You can see the explanation for this here: hidden link

Let me know if you need anything else regarding this.

Regards,

July 17, 2019 at 7:13 am #4226437

stephanieM-9

HI there,

Yes, both tags are there.
But if you look closely, the hreflang = "en" tag point to the wrong url. It should point to the hidden link rather than both pointing to hidden link

Many thanks

July 17, 2019 at 2:17 pm #4231191

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This happened to some users because of duplicate plugins and redirect plugins.

Could you please disable all the plugins except WPML plugins and check the issue?

Let me know.

Regards,

July 18, 2019 at 12:21 am #4234029

stephanieM-9

Hi there,

I did disable all the plugins except WPML plugins but the issue is still there.

Many thanks,

July 19, 2019 at 4:10 am #4243807

stephanieM-9

My issue is resolved now. Thank you!