This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Bobby 5 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
October 18, 2018 at 7:33 am

olcayy

i added a new language: turkish hidden link title and description where is the setting place?

home source hreflang tags do not appear

October 18, 2018 at 7:52 pm #2829423

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

The hreflang tags only appear on a page if there is a published and linked translation for which the hreflang tag displays the alternate language as the language switcher would show.

i can currently see that you have not yet added any translations , please add the translations or go to WPML->Settings->Post Types Translation -> "Translatable - use translation if available or fallback to default language"

and this will use the default language as a fallback to display the translation.

additionally you can add a language switcher from within WPML->languages-> Menu Language switcher

October 19, 2018 at 12:35 am #2829853

olcayy

I did not improve 🙁

October 19, 2018 at 5:30 pm #2832768

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please go to Pages -> add a translation to the page you are viewing.

the page needs to be translated first , or duplicated over to the secondary language

let me know your results

October 19, 2018 at 7:07 pm #2832865

olcayy

Hello, I've added a page
Nothing changed 🙁
can you please

October 19, 2018 at 7:56 pm #2832929

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i created a test page called "WPML Test" and duplicated it over to Turkish.

after checking its page source i can see the source as expected with the href lang.

also regarding your string translation , please make sure that once you are done with the translation you check the box for " Translation is complete " and then save, otherwise the translation will not effect.

October 19, 2018 at 8:18 pm #2832991

olcayy

still english
and no hreflang

October 19, 2018 at 8:30 pm #2833033

olcayy

how do I set title and description to the languages ​​I added
and hreflang

I don't want to add pages

October 19, 2018 at 9:09 pm #2833088

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

this is happening because you have select your homepage to "display the latest posts" from within Settings->Reading.

when setting your homepage to "display latest posts" you are essentially just showing all the posts , if you translate your posts and then access them one by one you will see that each post will have a hreflang assigned to the source

but the homepage it self is not a page that exists and that you have translated therefore it will not show a hreflang and instead each individual post will have its own.

October 19, 2018 at 9:43 pm #2833112

olcayy

I do not understand you. you say different things

i'll have to remove this plugin
no support turkish

October 19, 2018 at 9:48 pm #2833114

olcayy

ftp, wp-admin I gave you information
can't you set title, hreflang and description?

October 19, 2018 at 9:54 pm #2833116

olcayy

Why do English articles appear in Turkish?

October 19, 2018 at 11:53 pm #2833202

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

1. The posts are showing because the option within WPML->Settings->Post Types Translation -> Translatable - use translation if available or fallback to default language was activated for pages/posts as a test

this has been reverted back , and now these will only show if you translate the pages/posts

2. Your website has been set up to show "the latest posts" for the homepage

this is done through WP->Settings->Reading-> "Display latest posts"

when using this option you are not using a dedicated static homepage to show your posts rather you are allowing WordPress to just display them.

this is why you are not seeing any hreflang attributes, since this is not a page that has any translation within it.

and as mentioned earlier "The hreflang tags only appear on a page if there is a published and linked translation for which the hreflang tag displays the alternate language as the language switcher would show."

therefore since your Home page is not an actual page it does not have the hreflangs

You can do a workaround for this by creating a page and using a shortcode to display all your posts within the new page

then go to Settings->Reading->Set the new page as the static homepage

this way the hreflang will be correctly assigned.

hidden link

October 20, 2018 at 6:01 pm #2834485

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If possible try the above as a workaround solution (to assign the posts to a dedicated page)

meanwhile i will be escalating this to our developers to take a closer look, as i was able to replicate it with a clean install to verify that it is not a bug.

i will be updating you as soon as possible.

October 22, 2018 at 5:58 pm #2839314

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i have resolved the string translation issue with your blog title and tag line , this was happening because the homepage one was under the domain of admin_texts_wpseo_titles in String Translation.

after translating it , the title and tag line show correctly. [screenshots]

regarding the home page hreflangs , since this is a dynamic page to show your posts and not a static page , our developers are taking a look at this currently and i will be updating you as soon as there are news.

The topic ‘[Closed] hreflang & title’ is closed to new replies.