This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
html not parsed in Enfold contact form fields / labels

Solution:
You had to allow the HTML tags in Enfold contact form fields / labels.
So I added this code to WPML > Settings > Custom XML Configuration to allow the HTML tag there.

<wpml-config>
	<shortcodes>
		<shortcode>
			<tag>av_contact_field</tag>
			<attributes>
				<attribute encoding="allow_html_tags">label</attribute>
			</attributes>
		</shortcode>
	</shortcodes>
</wpml-config>

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by massimoS-6 5 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
March 10, 2019 at 10:39 am #3303745

massimoS-6

I have translated a contact form in contact page of the website hidden link

There is a checkbox with some text that has html embedded in the original. When I tried to translate it html markup is considered as text as you can see here:

hidden link

How to solve the problem?

Thank you,
Max

March 10, 2019 at 11:40 am #3304009

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support and sorry for the delay.

Usually, links are allowed in String Translation.
Can you please check if that string is used in a place where links are allowed and not stripped out? You can ask your theme/plugin support if you do not know about this.

And, to check the links/url in string translation, you can add a link in the default language.

I doubled check in a default theme (twenty seventeen) and the link works: hidden link and hidden link

Regards,
Riffaz.

March 10, 2019 at 12:18 pm #3304203

massimoS-6

Hello and thank you,

I have not translated that in string translation but using your translation editor.
I have checked the string translations and I have found the text there as well, so I have translated it also using the string translator. The problem persists, could it be because of a conflict?
I suppose that links are not stripped out or not allowed in that page or they would not work in the original as well.

March 10, 2019 at 2:38 pm #3304555

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Let me know your site login details to check this closely.

Regards,

March 17, 2019 at 8:28 am #3362909

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This is fine now: hidden link

You had to allow the HTML tags in Enfold contact form fields / labels.
So I added this code to WPML > Settings > Custom XML Configuration to allow the HTML tag there.

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>av_contact_field</tag>
            <attributes>
                <attribute encoding="allow_html_tags">label</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Please confirm close this ticket.

Regards,

May 4, 2019 at 4:26 pm #3740773

massimoS-6

Hi and thank you Riffaz,

now I have the same problem on the headlines rotator in the homepage.
Is there a way to tell WPML that everything must be as it is in the original language?
If you need it, the user I have created for you the last time is still valid.

Thank you,
Max