Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Mohamed Sayed 6 months, 2 weeks ago.

Assigned support staff: Mohamed Sayed.

Author Posts
March 14, 2022 at 6:08 pm #10787165

andreaB-8

I am trying to go to EN version

I get this error

HTTP code: 500 (Internal Server Error)

I've seen in you docs that there is an issue about /en folder

I don't know how to resolve it.

Can you help me?

I need to have English version on

hidden link

March 14, 2022 at 7:01 pm #10787487

Laura
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Before your ticket is assigned to one of my colleagues, please allow me to walk you through some initial debugging steps. This will help speed up the support process.

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

March 14, 2022 at 11:45 pm #10788299

andreaB-8

I inserted

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

nothing changed

and in

/wp-content/debug.log

I don't have debug log

Can you access and resolve from your side?

Thanks!

March 15, 2022 at 4:30 pm #10795413

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi there,
Thanks for contacting WPML support.

I would need to request temporary access (WP-Admin and FTP) so I can investigate this issue further.

– preferably to a test site where the problem has been replicated if possible –

Your next answer will be private, which means only you and I have access to it.

❌ Please backup your database and website before providing us with access details ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme and to change configurations on the site if needed. This is also a reason the backup is critical.

Thanks for your cooperation.

Regards,
Mohamed

March 15, 2022 at 10:56 pm #10797281

andreaB-8

OK do all what you need! allow me to provide username and pass for access

March 16, 2022 at 8:31 am #10799935

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I've enabled the private reply so you can share the login details.

March 16, 2022 at 10:58 am #10801789

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for providing the access details.

The issue was fixed after resaving the permalinks structure settings in Settings > Permalinks. Now I can access the English language as you can see here: hidden link

Regards,
Mohamed

March 16, 2022 at 11:14 am #10801889

andreaB-8

Thank for your help!

Why this happens??

Thanks!

March 16, 2022 at 11:31 am #10802157

Mohamed Sayed
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I'm not sure because there are no errors that can help to find out the reason for this issue.

If the issue happened again, I suggest trying the following:

1) Check with your hosting provider for the server error log (If exists) which might show some related errors.

2) Create a full backup then update all plugins including the WPML ones to the latest version, I noticed that many of your plugins are outdated.

3) Increase the WordPress Memory Limit. According to your Debug.info, the WP memory limit needs to be increased. PHP memory is fine, but WordPress uses 40Mb as default. Minimum requirements for WPML is 128Mb. (Kindly check this page https://wpml.org/home/minimum-requirements/)

You can increase it by adding the following code in your wp-config.php file, right before the /* That’s all, stop editing! Happy publishing. */ line:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Regards,
Mohamed