This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to save my page, but operation of save get lots of time and finally get error 500. I got very huge usage of CPU

Solution: The foul was by Litespeed plugin.

Relevant Documentation:

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 25, 2019 at 10:47 am #4453909

Jacek

I am trying to:

save my page, but operation of save get lots of time and finally get error 500. I got very huge usage of CPU

I also got email:
"
Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

WordPress wykrył błąd w używanej wtyczce: WPML Multilingual CMS.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.
"

If WPML Multilingual CMS is disable, the problem is gone

I found that ticket

https://wpml.org/forums/topic/huge-cpu-usage-on-saving-pages/

and I was try add this code

if( defined( 'DOING_AJAX' ) && DOING_AJAX ) { wp_die( '0', 400 );

to wp-config.php, but it brake my site

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

August 26, 2019 at 9:49 am #4457289

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to visit this link and follow the steps described: https://wpml.org/faq/prevent-performance-issues-with-wpml/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

August 29, 2019 at 6:30 am #4477991

Jacek

Thanks for help.

The foul was by Litespeed plugin.

August 29, 2019 at 2:13 pm #4481699

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos