Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
The size of icl_string_pages is growing huge. How can I stop this from happening?

Solution:
If the table is growing, one of the possible causes for that behaviour would be creating duplicate strings on new pages. If there are dynamically generated strings that would be causing this increase, you would see a parallel increase also in the table _icl_strings. Please check if this is the case.

You can check sorting the table by IDs and check if there is a specific page generating all this strings. You could check the latest strings to see if they are different or the same and exclude the text-domains to which they belong from auto-registering in WPML > String Translations.

Another possible cause for this is aggressive caching for logged users, that could be registering strings more than once. If you have identified a specific page generating many of these strings, please check the caching for this page and disable it for logged-in users.

Also, try reducing the size of the tables. You can run this MySql query instead of deactivating and reactivating the plugins:

TRUNCATE TABLE wp_icl_string_pages;
TRUNCATE TABLE  wp_icl_string_urls;

Then, go to WPML > String Translation > Auto register string for translation > Edit and exclude all the text domains.

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by Ariel 1 year, 7 months ago.

Assigned support staff: Lauren.

Author Posts
May 8, 2018 at 8:44 pm #2040338

Ariel

I am trying to:I'm using WPML 3.7.0 and cant accces my site because wp_icl_string_pages table has almost 20 million entries. What should I do?

Link to a page where the issue can be seen: lepetitsuites.com

I expected to see:

Instead, I got:

May 9, 2018 at 8:16 pm #2061003

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please backup your site in all cases to prevent data losses.

If the table is growing, one of the possible causes for that behaviour would be creating duplicate strings on new pages. If there are dynamically generated strings that would be causing this increase, you would see a parallel increase also in the table _icl_strings. Please check if this is the case.

You can check sorting the table by IDs and check if there is a specific page generating all this strings. You could check the latest strings to see if they are different or the same and exclude the text-domains to which they belong from auto-registering in WPML > String Translations.

Another possible cause for this is aggressive caching for logged users, that could be registering strings more than once. If you have identified a specific page generating many of these strings, please check the caching for this page and disable it for logged-in users.

Also, try reducing the size of the tables. You can run this MySql query instead of deactivating and reactivating the plugins:

TRUNCATE TABLE wp_icl_string_pages;
TRUNCATE TABLE  wp_icl_string_urls;

Then, go to WPML > String Translation > Auto register string for translation > Edit and exclude all the text domains.

Please let me know if any of these steps improves the size of the table. To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

May 10, 2018 at 12:13 pm #2070839

Ariel

Thanks! Problem solved.