This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After migrating my site from Polylang my site is missing some content.

Solution: Follow the documentation at the documentation here: https://wpml.org/documentation/related-projects/migrate-polylang-wpml/.

In this case, the site was using a custom theme with many custom widgets. To resolve the issue may require custom programming on your theme developer's part. However, we can try one more thing.

Please create a separate widget in Appearance -> Widgets -> Footer 1 Column. Create one widget for English and one for Arabic. Then, in your Arabic widget, set the page widget to the Arabic page where you have created the menu. Please keep in mind that you will need to translate each menu as well as each page where these page widget/menus are created.

Be sure to set each widget to their respective language after they are created.

This topic contains 8 replies, has 2 voices.

Last updated by khalidA-23 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 29, 2018 at 3:55 am #2775307

khalidA-23

Tell us what you are trying to do?
I migrated from Polylang to WPML but I don't know how to use WPML..

Is there any documentation that you are following?
No

Is there a similar example that we can see?
go to see kahdal.com The Arabic interface that I made with Polylang is gone.

What is the link to your site?
kahdal.com

October 1, 2018 at 4:49 pm #2778879

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If you are trying to migrate Polylang content to WPML content, then I suggest following the documentation here: https://wpml.org/documentation/related-projects/migrate-polylang-wpml/

Once you have followed those steps, let me know if everything is working okay or if you need further assistance.

October 1, 2018 at 5:11 pm #2778953

khalidA-23

Hi,
I followed exactly the migration instructions and I am still confused and the Arabic interface is still not shown. I still need assistance.

October 1, 2018 at 5:17 pm #2778958

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Does your Arabic content show on the backend of your site? Please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Now is your content appearing?

October 1, 2018 at 5:25 pm #2778970

khalidA-23

I did the database backup before doing the migration process. I facing the following:
1. The Header Menue in Arabic is not showing.
2. The Engllish pages when I click on duplicate the entire content.. it gives me different output.

I need a video tutorial on how to use the WPML for the first time or at least you can guide me.

October 1, 2018 at 6:27 pm #2779183

khalidA-23

All Arabic pages are empty.. I don't know what to do.. Do I need to all of them and recreate them again using the WPML? Or how to copy the entire English content or duplicate it without the need of recreating the pages again. I am confused! The duplicate button is not doing anything.

October 1, 2018 at 7:07 pm #2779242

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 3, 2018 at 1:56 pm #2784738

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like you are using a custom theme with many custom widgets. To resolve the issue may require custom programming on your theme developer's part. However, we can try one more thing.

Please create a separate widget in Appearance -> Widgets -> Footer 1 Column. Create one widget for English and one for Arabic. Then, in your Arabic widget, set the page widget to the Arabic page where you have created the menu. Please keep in mind that you will need to translate each menu as well as each page where these page widget/menus are created.

Be sure to set each widget to their respective language after they are created. If this does not resolve the issue, you will need to open a new ticket, since this is a new issue and not related to what the ticket was originally opened for. Thanks for understanding.

October 7, 2018 at 4:19 am #2793473

khalidA-23

My issue is resolved now. Thank you!