This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by manuelC-26 2 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
July 30, 2019 at 2:28 pm #4308471

manuelC-26

I am trying to: Translate this product from portuguese to english hidden link. I translated with WPML, however the link is broken on the english version of the website. Also, when I am going to translation management this is the only product I cannot visualize the page (see image attached)

Link to a page where the issue can be seen: hidden link

I expected to see:

Instead, I got:

July 31, 2019 at 5:01 am #4311465

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

So this is the only product you can't edit? If you try from the WooCommerce Multilingual page instead of from Translation Management, do you see any difference?

I would also need your WPML debug information. You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

July 31, 2019 at 12:06 pm #4314147

manuelC-26

Hi, I can edit the product, however I cannot edit it via woocommerce multilingual. Let me explain:
- When I am going through woocommerce multilingual, I see the image 1 (the same as if I go through WPML translation management);
- After completing the form on woocommerce multilingual I am not going to page you can see in the image 2 (that's what happens in the other products).

It seems the product page is not created even if I complete the form over and over again.

August 1, 2019 at 7:14 am #4319201

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the first screenshot is from the Advanced Translation Editor, while the second one is from the Classic Editor.

If you created a product with the Advanced you shouldn't see the Classic for the edit, but you should go to the Advanced again. If this is what happens, then it's correct.

It might be that the Advanced Translation Editor can't deliver your translation. If you go to WooCommerce > WooCommerce Multilingual and search for this specific product, what icon do you see?

If it's the gear icon, can you go to WPML > Settings and click on "Synchronize translators" and try to deliver the translation again?

August 6, 2019 at 9:12 am #4345649

manuelC-26

Hi,

For this specific product I can only see the classic editor, the page do not move to the advanced translation editor as happened in the other products. As a result the product page is not created at all. I already tried to synchronize translators and nothing happens. How can I solve this?

August 6, 2019 at 11:49 am #4346997

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

please provide credentials and the exact name of the product you have issues with so I can check it better.

I'll enable a private reply.

August 6, 2019 at 5:01 pm #4349677

manuelC-26

My issue is resolved now. Thank you!