This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Mihai Apetrei 6 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
April 12, 2019 at 4:43 pm #3600645

sophieB-9

I am trying to: customise/update my second (parallel)language site. Update fails every time.

Link to a page where the issue can be seen:hidden link

I expected to see: my changes updated.

Instead, I got: message: update failed

April 12, 2019 at 5:16 pm #3600915

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased as the minimum requirement for WPML is 128Mb WP Memory Limit: https://wpml.org/home/minimum-requirements/

❌ Very important: please make a backup of your site (files & database) before following any of the upcoming steps ❌

Please add this to your wp-config.php file to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so, if that’s the case, I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

2. From what I can see, you are having a very old WPML version so you might need to update manually.

First of all: please create a full backup of the site - it is VERY important that you do that first, so please DO NOT go forward without doing that first.

After that, please follow the steps below:

  • download the latest version of WPML from https://wpml.org/account/downloads/;
  • disable WPML Multilingual CMS on your site
  • delete WPML Multilingual CMS on your site(the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML plugin from Plugins → Add New → Upload Plugin
    → Activate WPML
    ;

Please let me know if this solves the issue or if you need further details.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week in case you will answer this weekend and you will still need help.

I will be waiting for your response.

Kind regards,
Mihai Apetrei