This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to save the page (Velten Media development) but the ACF flexible content group Whitepaper download won't save its values.

Solution: Could you confirm that you set the system fields associated to the ACF to 'translate' too? Remember that for each ACF there are two entries in the custom fields section and both have to be set to 'translate'.

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 1, 2019 at 9:56 am #4117579

Nick

I am trying to save the page (Velten Media development) but the ACF flexible content group Whitepaper download won't save its values.

Link to a page where the issue can be seen:hidden link

I expected to see: New Values within the ACF group Whitepaper downloads;

Instead, I got: No new values and empty fields.

July 1, 2019 at 11:31 am #4118459

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to visit this link where you will find the steps to follow in order to translate Advance Custom Fields using WPML: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Note: Please contact your hosting providers and ask them to update the PHP version too.

Kind regards,
Carlos

July 1, 2019 at 12:54 pm #4119139

Nick

Hi Carlos,

We could not find the solution for our problem within the things you mentioned. We keep having problems with new ACF fields not being translated.

We select translate for every ACF field, but the value would not change. Even after deleting the translation of the ACF group and duplicating it again. The new fields won't save there values.

July 1, 2019 at 1:00 pm #4119167

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you confirm that you set the system fields associated to the ACF to 'translate' too? Remember that for each ACF there are two entries in the custom fields section and both have to be set to 'translate'.

Also, does the issue persists if you set the Group Fields to 'Not translatable' after setting all of the custom fields to 'translate'?

Regards,
Carlos

July 1, 2019 at 3:04 pm #4120499

Nick

My issue is resolved now. Thank you!

July 1, 2019 at 3:19 pm #4120723

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos