If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was trying to translate a gravity form, but got a blank page when saving.

Solution: The problem was due to server memory limit. Increasing it solved the issue.

This topic contains 13 replies, has 2 voices.

Last updated by mirko 4 years, 6 months ago.

Assigned support staff: Otto.

Author Posts
April 24, 2015 at 1:33 pm #605687

mirko

I am trying to: trabnslate gravity form but every time i try to translate it it gives me blank page

URL of (my) website where problem appears:www.shuttlerace.it

I expected to see:

Instead, I got:

April 24, 2015 at 3:16 pm #605799

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

Can you share the debug information with me, so I can be of better help?

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/,
2. Repeat the action of trying to translate a gravity form
3. Copy and paste the contents of error_log.txt here for me to see

Thank you!

April 24, 2015 at 3:28 pm #605809

mirko

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 1146880 bytes) in /usr/local/psa/home/vhosts/shuttlerace.it/httpdocs/w/wp-includes/functions.php on line 3282

and i have added in config.php this define('WP_MEMORY_LIMIT', '64M');

April 24, 2015 at 5:25 pm #605898

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

Thanks for sharing the info.

Let's try to debbug the issue.

Could you please try to increase the memory limit to 256?
http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

And please make sure that the change is taking effect? Sometimes hosting providers don't allow changes via wp-config.php. You may want to instal this plugin to check: https://wordpress.org/plugins/query-monitor/

If you switch to Twenty-fifteen theme the problem still appears or not?

If the last one does give an error, please deactivate all non related plugin. If the issue is gone, active your plugins one-by-one, and check when the error comes back.

Let me know if this helps

Kind Regards

April 24, 2015 at 7:16 pm #605962

mirko

Hi,
ii have installed query monitor and i have 64 memory limit.
i cant go to 256, i can ask to my provider but i doubt it will make the change

After installing query monitor i had blank pages caused to same error...so i tried to switch theme to default one.

With twenty-fifteen theme i have no problem at all (
all work as intended.

The theme i bought is soul medic from themeforest, and as you can see hidden link it tells is 100% wpml compatible.
but i think there is some problem.
I already contacted theme creator and he told me to contact your support, and so i have done.

how can i resolve this?
ty

April 24, 2015 at 9:14 pm #606021

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

Just to check, you modified your wp-config.php file to:
define('WP_MEMORY_LIMIT', '256M');
but the limit is still 64MB, right?

Please try to ask your hosting provider to increase the limit. I think you'll get it.

It looks like is the theme that you are using what's consuming memory. As you tried with other theme and worked fine and the new blank pages. It doesn't look like a compatibility issue neither, resource intensive theme.

Please check this thread: hidden link (look for "memory" in the page)

Is it possible for you to try with a local install? That's another way to check if it's only a memory issue.

Let me know if that doesn't work. I'll try to help you solve the issue.

Kind regards

April 24, 2015 at 9:35 pm #606030

mirko

Hi,
It is correct. I set memory limit to 256 but got only 64.
I will send request to my hosting but they will probably answer me only on monday, i hope they will change it also if i doubt it.

I dont understand instead what you mean for local install?
Let me know and thank you

April 27, 2015 at 1:12 pm #606922

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,

Any luck with the memory increase?

What I meant with local install, is to install your site and content in your computer. There you can set the memory limit to whatever you want, so is a good way to test if it's a memory issue (I'm almost sure it is).

If you wish I can test it for you. For this you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. In order to provide me with the snapshot follow these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won't be able to login. You may delete the new admin account once the snapshot has been built.

Once the problem is resolved I will delete the local site.

I'll set next reply as private so you can send me the download link.

Regards

April 27, 2015 at 1:28 pm #606936

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Great!
Please, do let me know, so I'll set a private answer for you to share that info.
Regards

April 27, 2015 at 1:29 pm #606937

mirko

ok)

April 28, 2015 at 11:53 am #607772

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi,
Did the memory increase solved the issue?
Kind Regards

April 28, 2015 at 12:41 pm #607834

mirko

Yes, i think it is solved. i never had problems anymore, but give me 24 more hour to check it all)
ty

April 30, 2015 at 11:53 am #609622

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Sure, thanks.
Let me know when you test that it works fine.
Kind regards

May 11, 2015 at 7:15 am #615950

mirko

Now all works perfcet,
thank you Otto)