If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 1 voice.

Last updated by katalinZ 3 months, 3 weeks ago.

Assigned support staff: Marcel.

Author Posts
July 26, 2019 at 7:28 am #4287887

katalinZ

Hi,

I can not add new page with active wpml. If I deactivate it, i can add new pages again.
I got a letter with this:

A(z) /inclust-ssd/p3/2925/web/wphonlap.eu/www/danubia/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php fájl 32 sora egy E_ERROR típusú hibát okoz. Hibaüzenet: Uncaught InvalidArgumentException: element_id and type do not match for element_id:1401 the database contains post_attachment while this function was called with post_page in /inclust-ssd/p3/2925/web/wphonlap.eu/www/danubia/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32
Stack trace:
#0 /inclust-ssd/p3/2925/web/wphonlap.eu/www/danubia/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1489): WPML_Set_Language->set(1401, 'post_page', false, 'hu', NULL, true)
#1 /inclust-ssd/p3/2925/web/wphonlap.eu/www/danubia/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(325): SitePress->set_element_language_details(1401, 'post_page', false, 'hu', NULL)
#2 /inclust-ssd/p3/2925/web/wphonlap.eu/www/danubia/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(172): WPML_Post_Translation->maybe_set_elid(false, 'page', 'hu', 1401, NULL)
#3 /inclust-ssd/p3/2925/w

What can I do?

Thanks,

Kate

July 26, 2019 at 8:12 am #4288249

katalinZ

My issue is resolved now. Thank you!