This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Riffaz 10 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
October 11, 2018 at 4:03 am #2806630

chun-yenl

Hi,

I already install and activate Yoast SEO and WPML, but I can not find custom field for title / meta description in product edit page. Could you please tell me how to find title / meta description related custom field?

ex page:hidden link (Site with WooCommerce, theme WoodMart, hidden link)

The custom field in my product edit page:
_wpml_word_count
_wc_review_count
_wc_rating_count
_wc_average_rating
_wpml_location_migration_done
woodmart_sguide_select
yikes_woo_products_tabs
_sku
_regular_price
_sale_price
_sale_price_dates_from
_sale_price_dates_to
total_sales
_tax_status
_tax_class
_manage_stock
_backorders
_sold_individually
_weight
_length
_width
_height
_upsell_ids
_crosssell_ids
_purchase_note
_virtual
_downloadable
_product_image_gallery
_download_limit
_download_expiry
_stock
_stock_status
_product_version
_price
_product_360_image_gallery
slide_template
_yoast_wpseo_primary_product_cat
_woodmart_single_product_style
_woodmart_thums_position
_woodmart_custom_sidebar
_woodmart_extra_content
_woodmart_extra_position
_yoast_wpseo_content_score
_wp_old_date
_woodmart_new_label
_woodmart_product_custom_tab_title
_woodmart_product_custom_tab_content
_wpml_media_has_media

October 11, 2018 at 3:15 pm #2808859

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Actually, the configuration for Yoast SEO is loaded from here
hidden link
You shouldn't need to set anything

I could be able to translate them when I press + sign on the product edit page: hidden link
I see this hidden link when I pressed that button.

All you have to do it set the products translatable in WPML > Settings > Post Types Translation or in the edit product edit page: hidden link

Even if you could not translate them like I explained you can always translate them in your second language YOAS SEO Matabox by clicking it here : hidden link

If you still could not do this let me know your site login details to check this.
I've set the next reply to be private. So only you and I can see that.

Let me know.

Ps:
Sorry for the delay.
I've been checking all this in my local host to provide an accurate answer.

Regards,
Riffaz.

October 12, 2018 at 5:10 am #2810813

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Seems your login details are incorrect.
I see this when I try to login : hidden link

Regards,

October 12, 2018 at 8:38 am #2811260

chun-yenl

Please choose {Log in with username and password} instead of Log in with WordPress.com

October 12, 2018 at 12:56 pm #2812035

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thanks for the updated details.

It seems like a bug.

In order to help you better I need to debug this issue locally, for this I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content.
Once the problem is resolved I will delete the local site.
I hope this okay?

Ps:
We do not work on weekends.

Regards,

October 12, 2018 at 2:12 pm #2812263

chun-yenl

Ok, go ahead, thanks. Have a nice weekend.

October 15, 2018 at 7:50 pm #2818637

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Riffaz is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

I've read this ticket, but I'm not sure that I understand the issue.
Could you please explain to me what is the problem regarding WPML?
You are mentioning that this problem is related to the Yoast SEO plugin, but I do not understand how the list of the custom fields that you attach in your first reply is connected to the Yoast plugin.
Do you simply need to translate those fields?
If so then you need to set them to be translated, but you should know that not all of them might need to be translated. The translation options for custom fields are, 'Translate', 'Copy', 'Copyonce', Don't translate'. Please see our documentation about translating custom fields here.
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Could you also please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

October 17, 2018 at 6:27 am #2823213

chun-yenl

Do I need to provide login info? I can wait Riffaz!

October 17, 2018 at 3:31 pm #2825150

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

To your request, I've assigned this ticket back to Riffaz, and he will continue to handle this ticket. Please wait for his reply.

P.S. It seems that the access details to your site work now.

Best Regards,
Itamar.

October 18, 2018 at 2:15 pm #2828286

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Chun,

It was just a mistake.
You should have something filled in your main language product SEO title and description to see them in the translation editor.

I see them in translation editors after I added some text in your main language product SEO title and description.
See: hidden link

You have to fill the title and the description here : hidden link

Let me know the result please after you try this.

Regards,

October 18, 2018 at 2:34 pm #2828376

chun-yenl

Great, I know how it works now. It will be great if you can modify your document and emphasize that user must add title / meta description / og title / og description manually instead of using default setting / pattern in yoast seo if they need to translate them. Many people just use the default setting, won't edit it manually. This ticket can be closed.

October 19, 2018 at 4:37 am #2830548

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Chun,

Thank you for confirming.

Yes, sure,. I already notified the documentation department regarding this.
They will update the doc soon.

A rating is appreciated. 🙂

Regards,