This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: If the customers come to visit the German site, and they want to move to front page again, they would click "home" button, but page does not go to home written in English

it stay there as German site.

Solution: The cause of this issue is that the Pages are set to be not translatable. To change this you need to go to WPML -> Settings -> Post Types Translation -> Set Pages to 'Translatable - only show translated items' -> Save the changes.

Then go to Pages and make sure the pages are correctly connected with their correspondent translations.

Relevant Documentation:

Tagged: 

This topic contains 23 replies, has 3 voices.

Last updated by goodok 4 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 6, 2019 at 6:16 pm #3751997

goodok

My issue is that when I click the "home" button, I can not move to home page (front page)

when you see the some page written in German, there is a drag and drop button for multi-language.

If the customers come to visit the German site, and they want to move to front page again

they would click "home" button, but page does not go to home written in English

it stay there as German site.

in other words, hidden link ->www.com (as a hompage)

but it moves hidden link ->www.com/de (as a result, it does not move)

above site is not mine, just an example

I don't know about programming. if possible, I want to correct a little

May 6, 2019 at 8:15 pm #3752533

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 6, 2019 at 10:03 pm #3752833

goodok

I did not back up my file yet. your time zone and my time zone is different. and when I just agree WordPress / server access, will you fix my issue? what is the next step?

May 7, 2019 at 10:17 am #3756295

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

In my previous message I asked you to share access to the site so I can take a closer look at the issue and see if there are any errors in the debug.log.

If you desire you can activate the debug mode on the site by following the steps described in this link: https://codex.wordpress.org/Debugging_in_WordPress and let me know if there is any message in the debug.log file within wp-content folder.

Note: Please create a full backup of the site before making any change and go to Settings -> Permalinks -> Re-save the permalink structre.

Could you tell me the result of the steps above?

Looking forward to your message.
Regards,
Carlos

May 7, 2019 at 3:46 pm #3759997

goodok

how can I make you can get WordPress / server access so that you can troubleshoot the problem? could you let me know? I can not activate the debug mode by myself. thank you

May 8, 2019 at 10:45 am #3765683

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 9, 2019 at 12:58 pm #3776261

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I tried to log in the site but the credentials didn't work. Please double check the credentials provided and edit your previous message if necessary.

Regards,
Carlos

May 9, 2019 at 4:35 pm #3778109

goodok

Hi, thank you. I check it twice. but there's no prolem
I am using Bluehost. this is the log in address
hidden link

using the id "greengrass.online", you can login
thank you ^^

May 9, 2019 at 11:27 pm #3779823

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for this new information.

This time I was able to log in the site. Before we continue I need to ask you to update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.

Note: Please don't forget to create a full backup of the site before making any change.

Please let me know if the issue persists after the steps above.

Regards,
Carlos

May 10, 2019 at 7:39 pm #3787693

goodok

Hi thank you
I solved one issue and there is other issue happened

as you said I updated WPML and activated WPML Multilingual CMS
and then I can move from "www.com/de"(written in German) ->"www.com" (home page)

but when I get to 'www.com" home page like above, language switcher in the main menu has gone. so I can not move to any other multilingual site

if you want I can give you an access to my site again
thank you

May 13, 2019 at 1:44 pm #3798969

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Carlos is not working today. If you don't mind, I'll continue with you on this ticket.

Yes, please provide access to your website so I could check this further.Please make sure to have a database backup.

Best regards,
Jamal

May 13, 2019 at 6:47 pm #3801231

goodok

thank you but in that case, I have explain it again. someone doesn't understand what my issue was. if carlos doesn't mind, I want him to continue again. thank you. have a nice day.

May 14, 2019 at 11:05 am #3806173

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Carlos is currently on vacation and would be back on Monday.
If you want to wait for him, I'll write to him about this and he will take care of the ticket on Monday. If you want us to continue with you, it would be my pleasure to help.

Best regards,
Jamal

May 14, 2019 at 4:13 pm #3809069

goodok

Hi there. No offence. I will wait carlos until he comes back. Please, let him know. when I have to explain my issue, It could be bothering. eventhough my Engish is not perfect, I think carlos could undetstood my words and he will fix my issue. anyway, thank you have a nice day.

May 14, 2019 at 6:07 pm #3809827

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Sure 🙂

I'll write to him. Have a nice day as well.
Jamal